Intel tool chain integration problem with Eclipse

Intel tool chain integration problem with Eclipse

Hello,

I have installed Intel Parallel Studio xe 2013 update1 and eclipse version 4.2.1.

I have followed the instructions in the "get_started_lc.htm" (Ran the compilervars.sh, exported CDT to eclipse)

I have created a hello world c (and also c++) project and selected Intel tool chains. However, when I build the project, I see the following error:

java.lang.NullPointerException

When I change to linux gcc tool chain, it builds and runs fine.

PS: I also have OpenJava installed for JRE

Please help.

Thanks,

Hari

8 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Hi,

     I encounted the same problem: java.lang.NullPointerException

This error is simple, but to find the root cause is difficult.

Hi,

     Please kindly check the uploaded screenshot. Thank you.

Fichiers joints: 

Fichier attachéTaille
Télécharger screenshot.jpg318.83 Ko

Hi Hari,

            You have to source the Intel compiler script that would set the necessary ENV vars. So could you please do the following before starting the eclipse:-

1. source /opt/intel/composer_XE_Version/bin/compilervars.sh [ia32/intel64]

2. ./eclipse

Hope this resolves the issue. See this forum about the same issue :-  http://software.intel.com/en-us/forums/topic/353348

Regards,

Sukruth H V

Hi Sukruth,

I have done that already.

I did read the link you mentioned, prior to my post. It does not resolve my issue.

The issue is kind of different here, I can select the Intel tool chain with out any error, just having problem when I build.

Thanks,

Hari

Hi Hari,

            I am investigating on this and get back to you with an update soon. Could you please let me know the OS that you are using and also the GCC compiler version?

Regards,

Sukruth H V

Hi Hari,

             This issue has been fixed in the latest Composer XE 2013 update 2. Please download it fron registrationcenter.intel.com.

Regards,

Sukruth H V

Hi Sukruth,

I an using fedora 17 and gcc version 4.7.2.20120921.

I have upgraded to composer XE 2013 update 2.....I still see the same issue.

Please execute the compilervars.sh to set the environment variable

$ source /opt/intel/composer_xe_2013.1.117/bin/compilervars.sh intel64

After declare the enviroment variable, the eclipse should work fine. (Tested with Indigo)

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui