problem in installing openmpi with ifort

problem in installing openmpi with ifort

Hi 

I have a question, I have an ifort 13 and mpif90 asssociated with that already installed. I want to get another mpif90 locally install which works with ifort 10. I installed ifort 10 but when I give the path of that to configure file of openmpi I am givving the following error :

"configure: error: Could not run a simple Fortran 77 program. Aborting."

I am using this command:

 " ./configure --prefix=/home/masoud/mpi10/ FC="/home/masoud/intel/fce/10.1.015/bin/ifort" F77="/home/masoud/intel/fce/10.1.015/bin/ifort" --enable-static --enable-mca-static CC=icc CXX=icpc   "

every thinf is fine if I use FC=ifort  F77=ifort instead but as we expect it install it with ifort13.

Thank you very much for your help

cheers 

 

2 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

You would need to set all environment variables consistent with ifort 10.1 and icc/icpc 10.1.  Then, the FC=ifort F77=ifort should produce an mpi consistent with ifort/icc/icpc 10.1.  I don't think you will be able to mix ifort 10.1 with icc 13.0, if that is what you intended.  You could also use ifort 10.1 together with gcc/g++, as you must have a version of those installed which works with ifort 10.1.

Your configure log should show at least what compile command was the basis of the report "could not compile a simple F77."  I guess you didn't have libraries on path which work with ifort 10.1.

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui