IFLangServicePackage

IFLangServicePackage

Hi,

  When compiling my mixed C++/Fortran Visual Studio 2012 solution from command line  using devenv.com I can see the following in the output before actual build process starts

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Is there something I can do to get rid of these messages?

23 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

How are you starting the command prompt session? Are you using the shortcut we provide, or calling ifortvars.bat (or one of our other .bat files) from your session? Does the Fortran integration seem to work in Visual Studio?

Steve - Intel Developer Support

I'm running deven.com, supplying solution file and desired configuration and platform to build. The integration works fine, after I see the messages in question the solution compiles successfully.

I tried this on the C_calls_Fortran sample we provide and don't get these messages. Please create a simple Fortran-only "Hello World" project (such as the predefined console application) and see if you get the warning when building from the command line.

You didn't tell me how you start the command prompt session. Please try it from Start > All Programs > Intel Parallel Studio XE 2013 > Command Prompt > Parallel Studio XE with Intel Compiler 13.1 > IA-32 Visual Studio 2012 Mode

Steve - Intel Developer Support

Hello Steve,

I am also seeing the same problem after upgrading and would like to get rid of the warning.
The build step is executed from Visual Build with the log message below.

Kind regards,
Svend

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

12-06-2013 10:30:41: Building project step 3 - Build BKarrayFortLib...

Pre-processing...

Building configuration 'Release|Win32'...

Command: "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.com" E:\trunk\Applications\Innovation\Components\BuildScripts\..\BKarrayFortLib\BKarrayFortLib.sln /build "Release|Win32"

"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.com" E:\trunk\Applications\Innovation\Components\BuildScripts\..\BKarrayFortLib\BKarrayFortLib.sln /build "Release|Win32"

Microsoft (R) Microsoft Visual Studio 2012 Version 11.0.60430.2.

Copyright (C) Microsoft Corp. All rights reserved.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

Package 'IFLangServicePackage' failed to load.

========== Build: 0 succeeded, 0 failed, 4 up-to-date, 0 skipped ==========

Hello Steve,

Executing "call "%IFORT_COMPILER13%bin\ipsxe-comp-vars.bat" ia32 vs2012" before running the compiler removed the warning.
See log below.

Kind regards,
Svend

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

12-06-2013 10:59:15: -------------------- Starting Build: 'BKarrayFortLib.bld' --------------------

12-06-2013 10:59:15: Building project step 3 - Build BKarrayFortLib...

Pre-processing...

Building configuration 'Release|Win32'...

Command: "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.com" E:\trunk\Applications\Innovation\Components\BuildScripts\..\BKarrayFortLib\BKarrayFortLib.sln /build "Release|Win32"

C:\Windows\system32\cmd.exe /C @echo off&&call "C:\Program Files (x86)\Intel\Composer XE 2013\bin\ipsxe-comp-vars.bat" ia32 vs2012&&"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.com" E:\trunk\Applications\Innovation\Components\BuildScripts\..\BKarrayFortLib\BKarrayFortLib.sln /build "Release|Win32"

Intel(R) Parallel Studio XE 2013

Copyright (C) 1985-2013 Intel Corporation. All rights reserved.

Intel(R) Composer XE 2013 Update 4 (package 190)

 

Microsoft (R) Microsoft Visual Studio 2012 Version 11.0.60430.2.

Copyright (C) Microsoft Corp. All rights reserved.

========== Build: 0 succeeded, 0 failed, 4 up-to-date, 0 skipped ==========

12-06-2013 10:59:16: Build successfully completed (elapsed = 00:00:01).

Yes - if you're going to build a Fortran project from the command line, you have to establish the proper Fortran environment first.

Steve - Intel Developer Support

I would expect we have to do it when invoking the compiler executable directly or via an alternative make tool. When executing devenv.com against a solution I expect _exactly_ the same behavior as in Visual Studio GUI.

I was not familiar with devenv.com. I know that invoking devenv.exe usually works just fine here. I am not sure what the difference is and why it changes the behavior. However, when I try it, it works fine for me. I opened a regular command prompt window (not a Fortran window), invoked devenv.com solutionname.sln /build, and it worked. No errors.

Steve - Intel Developer Support

devenv.com is issentially the way to run Visual Studio from command line (http://msdn.microsoft.com/en-us/library/xee0c8y7(v=vs.80).aspx). Intel premier support currently has a snapshot of our code base for Issue Number 696480. The "Package 'IFLangServicePackage' failed to load." issue manifests there too. 

I have always used devenv.exe for this, but I guess devenv.com works too. I'll check out the Premier Support issue to see if I can reproduce it with that solution.

Steve - Intel Developer Support

I am seeing exactly the same issue using the hello world app created from the main program code appliaction wizard in visual studio. It does not matter if you use the intel command line console that you referred to or a microsoft visual studio equivalent, neither does it matter if you use deven.com or devenv.exe. It happens with both VS 2012 Update 1 and 2, and Parallel studio XE 2013 with update 1 and Update 4. I have seen this on 3 machines with different opeating systems but always x64.

Running VS with the log option show these errors...

  <entry>
    <record>70</record>
    <time>2013/06/15 21:31:31.847</time>
    <type>Information</type>
    <source>VisualStudio</source>
    <description>Begin package load [IFLangServicePackage]</description>
    <guid>{56D7953F-5CFD-4791-9972-775BD082BE92}</guid>
  </entry>
  <entry>
    <record>71</record>
    <time>2013/06/15 21:31:31.858</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [IFLangServicePackage]</description>
    <guid>{56D7953F-5CFD-4791-9972-775BD082BE92}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry>
  <entry>
    <record>72</record>
    <time>2013/06/15 21:31:31.859</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [IFLangServicePackage]</description>
    <guid>{56D7953F-5CFD-4791-9972-775BD082BE92}</guid>
    <hr>80004003 - E_POINTER</hr>
    <errorinfo>Object reference not set to an instance of an object.</errorinfo>
  </entry> 

Thanks for the log. I will pass this on to the developers and will let you know what they say.

Steve - Intel Developer Support

I also have this problem after installing Intel Fortran Composer XE 2013 (Update 5) on a machine with Intel 2012 and Visual Studio 2010. I get 5 copies of the message when running VS 2010 devenv.com where the Fortran paths have been set to the Intel 2012 compiler. The machine is a 64bit machine, but I am using Program Files (x86) tools.

I have tried repairing the integration of Intel and VS to no avail.

Steve, you said you would pass this on to your developers for a response.

Sorry, looks as if I dropped this. I will ask the developers for help. I did look at the Premier Support issue ovz mentioned, but there was no discussion there of this problem.

Steve - Intel Developer Support

I have been unable to reproduce this myself, and I tried various combinations. I was intrigued by slysemose's comment that invoking the "ipsxe" bat file made the warning go away - I agree that shouldn't be necessary. But I would ask all who see this problem what you are using to start the command session, and how do you get the path to devenv?

Steve - Intel Developer Support

I get the problem where a TFS build system issues the following command:

C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.com "some.sln" /Rebuild "Programs|Win32" /Out "some.log"

where some.sln contains some Fortran projects. No errors are generated for C only solutions.

Equally no errors are generated if the same command is entered into a command prompt.

VS2010 (devenv.exe) has been set to look for the Intel 12.1 compiler, but the errors are:

Package 'Intel.Fortran.IFLangService.IFLangServicePackage, IFLangService, Version=13.0.0.0, Culture=neutral, PublicKeyToken=null' failed to load.

Does this help?

I find it interesting that you get the errors from a TFS build and not from the command prompt. As for the version, you are using the VS integration from 13.x - the compiler version you've asked for may be different.

Steve - Intel Developer Support

Working with one of the affected users offline, we think we have figured this out and have put in a fix for the October update.

Steve - Intel Developer Support

We recently switched to using IVF 15 with Visual Studio 2013 and we get these messages when running devenv.exe in batch (the ones cited in the first message in this thread). We don't run ipsxe-comp-vars.bat, as was suggested earlier, but we have never had to in earlier releases, and this error does not occur when running VS 2013 interactively. We can add a call to ipsxe-comp-vars.bat to the process if necessary. Do we need to, and if so, why now and not with earlier releases (previously we were using IVF 12 & VS 2010, and we also used earlier releases before that)?

I don't know what is causing your problem. Did you try running the .bat file (you would want to "call" it) and see if the problem goes away? Maybe you have something in PATH that is interfering.

Steve - Intel Developer Support

No, as I said, we haven't tried that. I could set up a test to see it solves the problem, and I probably will. Fixing it in production is a little trickier because we don't run devenv from a batch file but from a python script. I was hoping to find out what it means and what the consequences are.

I just did an experiment opening a plain command prompt (not one of the Fortran build environments) and running devenv.exe from VS2013. It loaded fine and Fortran projects worked. All I can think of is that there's something extra in your PATH that is causing problems.

Steve - Intel Developer Support

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui