Intel® Parallel Studio XE 2013 for Linux Instillation errors

Intel® Parallel Studio XE 2013 for Linux Instillation errors

Dear Intel users,

I am trying to install 'Intel® Parallel Studio XE for Linux', on Linux Unbuntu (64 bit), but I am getting errors during the instillaion. I have downloaded 'parallel_studio_xe_2013_update3.tgz', from

https://registrationcenter.intel.com/regcenter/DownloadNow.aspx?ID=18197...

And I am using the 30 day free trial licence. During instillation I get an error saying:

--------------------------------------------------------------------------------
There are one or more critical unresolved issues which prevent the installation
from continuing.  You can fix them without exiting from the installation and
re-check. Or you can quit from the installation, fix them and run the
installation again.
--------------------------------------------------------------------------------
Missing critical pre-requisite
-- Intel(R) Composer XE 2013 Update 3 for Linux*: Trial license install of IA-32
product on Intel(R) 64 system with Debian* or Ubuntu* OS is not supported
--------------------------------------------------------------------------------

Does this mean that I cannot run this sofware on Unbuntu? Are there other distributions of Linux that it will run on? I am downloading this software specifically as I need the Intel C++ Compiler and the Intel Math Kernel Library.

Thank you very much for your help,

Aedan

4 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

By the way, what version of Ubuntu 64-bit do you use?

>>...You can fix them without exiting from the installation and re-check...

I can't verify the installation on Ubuntu but the error message looks like a warning '...You can fix them without exiting from the installation...'. Did you try to proceed with the installation?

Hi Sergey,

Thanks for your reply. I am using ubuntu 12.04 LTS. I couldn't proceed with the instillation as it gave an error saying it was missing critical pre-requisites. I also tried to install the c compiler and mkl libraries only, but this also failed. Do you know of any other way of installing them without installing Intel Parallel suite?

Thanks,

Aedan

Critical prerequisites usually refer to components of the linux distro, and there is a selection to view the missing prerequisites, which you didn't quote.   For example, simply installing g++ in a 64-bit distro nowadays doesn't provide components to support g++ -m32, as required for the icc ia32 compiler, but you should be able to install the "intel64" 64-bit compiler.  The full parallel studio product wouldn't make a difference in this respect.

The message quoted at the top of the thread implies that the 32-bit icpc hasn't been tested successfully with 64-bit Debian or Ubuntu 64-bit, but would work on an LSB-compliant distro (if you could install the 32-bit g++).  It would have been tested on red hat and suse, as you could see in the release notes.

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui