Lightweight Hotpots not working

Lightweight Hotpots not working

Hi,

I need help in running VTune Amplifier (Lightweight Hotpots).

I am submitting the screen-shot of the error output.

Also, I am getting the same error messages for Custom Hardware Analysis (on Xeon series).

Please advice.

regards,

Reshmi

Fichier attachéTaille
Télécharger vtune-lightweight-hotspots-error.jpg256.03 Ko
6 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

The version details is as follows:

Intel VTune Amplifier XE 2013

Product version - Update 2 (build 253325)

Hi Reshmi:

Are you profiling an application?  If so, how long did it run under profiling?  The image appears to suggest (in the log section) that profiling took much less than a second.  Is that correct?

Regards, MrAnderson

Hi Mr. Anderson, 

I was running a small application to see if the light-weight hotspots is working. It is working now & thanks for the help. 

When we ran the same command using the command line instead of GUI, it was giving us error. There were some issues with the Watchdog Timer & it was asking to "Disable NMI Watchdog when using PMU event-based sampling". 

This article really helped. 

regards,

Reshmi

this are the errors while doing the profiling of clusterw application.... i followed the steps from intel vtune amplifier doc but it wont work for viewing the source code ..... please help for the steps to profile any program and see the source code in vtune... i am using vtune in linux

this is error..

[kiran@sdp1 clustalw-mpi-0.13]$ amplxe-cl -collect advanced-hotspots -r profileadv ./clustalw-mpi -infile=CFTR.input -newtree=CFTR.mytre
amplxe: Error: Cannot start data collection. nmi_watchdog interrupt capability is enabled on your system, which prevents collecting accusampling data. Please disable nmi_watchdog interrupt or see the Troubleshooting section of the product documentation for details.
amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.
amplxe: Warning: On some systems based on the Intel microarchitecture code name Nehalem / Westmere with C-states enabled, this analysis stem hanging due to a known hardware issue (see errata AAJ134 inhttp://download.intel.com/design/processor/specupdt/320836.pdf). To avo, disable all "Cn(ACPI Cn) report to OS" BIOS options before sampling with VTune Amplifier on such systems.
[kiran@sdp1 clustalw-mpi-0.13]$ amplxe-cl -R hotspots -source-object function=calc_score -r profile/

amplxe: Using result path `/home/kiran/installdir/clustalw-mpi-profile/clustalw-mpi-0.13/profile'
amplxe: Executing actions 50 % Generating a report

amplxe: Error: An internal error has occurred. Our apologies for this inconvenience. Please gather a description of the steps leading upnd contact the Intel customer support team.

vcs/dvt/src/dicer/dvt_dicer_provider_query_impl.cpp(332): gen_helpers2::error_code_t dvt6_1::ProviderQueryImpl::executeQueryImpl(gen_hel_1::ITableTree> &, msngr2::IProgress *, int): IsNot Valid State
amplxe: Executing actions 100 % done
amplxe: Error: Error 0x40000024 (Reporter error)

    Hi kiran 

    Please read Reshmi post.He posted to link to Peter Wang article about NMI disabling.

    Connectez-vous pour laisser un commentaire.