LAPACKE_dgesvd crsahses for big matrices

LAPACKE_dgesvd crsahses for big matrices

Hi,

if I call LAPACKE_dgesvd in mode LAPACK_ROW_MAJOR, 'A', 'A' then the function does never return (also no error) for dimensions > 32x32. Is this a known bug or do I something wrong? I use latest MKL version.

Regards

11 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Hi,

this is an unknown problem. pls give us the example of your code for checking on our side.

regards

Hi,

meanwhile it works. But I don't know why. If I link it manually to mkl_core_dll.lib then it fails as described above. But if I use the "Use MKL=sequential" property in VS 2010 it works.

I dont' understand the differences. If I link my app manually with mkl_rt.lib, then svd function never returns for sizes > 32.
If I use the Project>Properties>Configuration Properties>Intel Performance Libraries>Use MKL>Parallel has same problem.
If I use the Project>Properties>Configuration Properties>Intel Performance Libraries>Use MKL>Sequential all is fine.

What goes wrong?

that's mean in the case when you use threaded version of MKL, then there is some problems.  In the case when you select Sequential item -- in that case, non threaded versions of MKL's libraries are used.

SO, how can I select sequential mode if I want to linking manually? Is this a known threading bug?

pls see the mkl linker adviser -- http://software.intel.com/en-us/articles/intel-mkl-link-line-advisor  to select list of libraries you need for linking.

DOes anybody know if this bug  will be fixed?

why do you claim this is the bug? Please give the example of the code which we can compile and execute on our side.

we don't know about such sort of issue with SVD routines. You can also look at the lapacke_dgesvd_col.c or lapacke_dgesvd_row.c examples and may be these examples will help you.

I did some further error analysis. SO if I use the  lapacke_dgesvd_row.c with an input of 50x50 all is fine in parallel mode.

But if I use !exactly! the same code in my app, it hangs in parallel mode for matrices > 32x32. Sequential mode is no problem.

I append the loaded modules output of my app. So what could cause this problem?

'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\cassandra.exe', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\ntdll.dll', Symbols loaded (source information stripped).
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\kernel32.dll', Symbols loaded (source information stripped).
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\KernelBase.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\psapi.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\version.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\msvcrt.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\pdh.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\rpcrt4.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\sspicli.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\cryptbase.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\sechost.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\advapi32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5Cored.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\user32.dll', Symbols loaded (source information stripped).
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\gdi32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\lpk.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\usp10.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\ole32.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\ws2_32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\nsi.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\msvcp100d.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\msvcr100d.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5Guid.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\opengl32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\glu32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\ddraw.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\dciman32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\setupapi.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\cfgmgr32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\oleaut32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\devobj.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\dwmapi.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5Widgetsd.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\shell32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\shlwapi.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5Xmld.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5OpenGLd.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5Svgd.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\cbl.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\cdl.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\cil.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\customipp.dll', Binary was not built with debug information.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\msvcr100.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\cml.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2013 SP1\redist\ia32\mkl\mkl_intel_thread.dll', Binary was not built with debug information.
'cassandra.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2013 SP1\redist\ia32\mkl\mkl_core.dll', Binary was not built with debug information.
'cassandra.exe': Loaded 'C:\Program Files (x86)\Common Files\Intel\Shared Libraries\redist\ia32\compiler\libiomp5md.dll', Symbols loaded (source information stripped).
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\cvw.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Projekte\Devel11\Base\Cassandra\bin\Debug\Qt5PrintSupportd.dll', Symbols loaded.
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\winspool.drv', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\comdlg32.dll', Symbols loaded (source information stripped).
'cassandra.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.7601.17514_none_ec83dffa859149af\comctl32.dll', Symbols loaded (source information stripped).
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\imm32.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Windows\SysWOW64\msctf.dll', Cannot find or open the PDB file
'cassandra.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2013 SP1\redist\ia32\mkl\libimalloc.dll', Binary was not built with debug information.
'cassandra.exe': Unloaded 'C:\Program Files (x86)\Intel\Composer XE 2013 SP1\redist\ia32\mkl\libimalloc.dll'
'cassandra.exe': Loaded 'C:\Program Files (x86)\Intel\Composer XE 2013 SP1\redist\ia32\mkl\mkl_p4m3.dll', Binary was not built with debug information.

I found the problem. It seems that if I call the svd method while application in startup phase, then this problem occurs. This is not a real problem but something curious.

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui