Bug in *GESVD when using MPI

Bug in *GESVD when using MPI

Hi,

Attached is a test case and screenshots where ZGESVD is sometimes computing the wrong lwork value when using MPI. This is the regular Lapack ZGESVD and not the Scalapack PZGESVD.  I have not checked, but I assume it occurs for all the *GESVD and not just ZGESVD.  If I remove the MPI specific code so I can run directly without using 'mpiexec', then the bug does not occur.  It only occurs when running with mpiexec to load the MPI library.  It also only occurs when one (or both) of the svd job types is 'N'.  If both svd job types are 'S', then it doesn't occur.

My platform is Windows 7, MKL 11.0.5, MPI 4.0.3.009.

Thanks, John

9 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

I don't see any files attached.  Could you show all of these?

Not sure how the files didn't get uploaded. Here they are.

Fichiers joints: 

Fichier attachéTaille
Télécharger compile_and_run.png100.8 Ko
Télécharger test_3.F903.88 Ko

Ok, I see the log now. You linking with integer8, so then can you please try to compile with /4I8.     or try to use integer4 instead of integer8 -- by another words use lp64 libraries instead of ilp64.

 

Even with lp64 and 4-byte integers everywhere I see the error.  Attached are the updated test file and compile/run output.

Fichiers joints: 

Fichier attachéTaille
Télécharger compile_and_run_lp64.png90.23 Ko
Télécharger test_3_0.F903.88 Ko

pls try the latest version 11.1 -- the simialar problem was fixed into this version.

See the Bug Fixed list : http://software.intel.com/en-us/articles/intel-mkl-111-bug-fixes  -- 

DPD200351579
Incorrect workspace size returned by query to DGESVD in MKL 11.0.5

Gennady,

Even with MKL 11.1, I still see the error.  I attached a simpler test case that does not use MPI but still exhibits the error.

Thanks.

Fichiers joints: 

Gennady,

In my previous post, I had downloaded MKL 11.1 but not the latest update.  When I use the latest version of MKL 11.1, the issue is resolved.  Thanks for your help.

John

Gennady,

In my previous post, I had downloaded MKL 11.1 but not the latest update.  When I use the latest version of MKL 11.1, the issue is resolved.  Thanks for your help.

John

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui