Debbugging Abaqus User Subroutines with Intel 12.0

Debbugging Abaqus User Subroutines with Intel 12.0

Dear friends,

I am trying to find a way to debug Abaqus user subroutines but, since I am using Abaqus 6.13/VS2010/Intel12, I am not able to do it, as most of the instructions online are oriented to older versions.

I change the abaqus_v6.env file to link it with my compiler the way that is recommended in many places (http://yhtian.wordpress.com/2010/11/03/debug-abaqus-subroutine-with-visu...) but the debugger is not able to find the PDB file (vc100.pdb).

I suppose that one way to overcome this problem is to create the obj and PDB files first, but when I try to do it with VS2010 the way I do it with my fortran codes a compilation error appears and no PDB or OBJ files are created. This is quite normal since what I am trying to debug/compile by "brute force" is a subroutine that has no sense without the main code, but I have seen online some people that made it this way.

Any advice? Thanks a lot for your help

Emilio Mtnez

 

 

3 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Emilio,

I'm working on your request. Which is your serial number and version of the product? Please answer via "Send Author A Message".

Thanks, Hubert.

I am experiencing the same problem using the Abaqus recommended configuration (abaqus 6.13 + VS2010 + Intel12.1). That is, I receive errors that the symbols (.pdb) cannot load in visual studio after attaching the process. Has anyone had success implementing debugging capability with abaqus 6.13?

Thanks,

Chance

Connectez-vous pour laisser un commentaire.