linux sdk problem?

linux sdk problem?

i refer http://software.intel.com/en-us/forums/topic/479998

i have error

code:

......

        sts = mfxSession.Init(impl, &ver);
        LOG_INFO("line:%d,sts:%d",__LINE__,sts );
        /* create va display */
        int fd = open("/dev/dri/card0", O_RDWR);
        LOG_INFO(" open fd:%d", fd);
        VADisplay va_dpy = vaGetDisplayDRM(fd);
        int maj_ver, min_ver;
        vaInitialize(va_dpy, &maj_ver, &min_ver);

        //Provide VA display handle to Media SDK
        mfxSession.SetHandle(static_cast < mfxHandleType >
        (MFX_HANDLE_VA_DISPLAY), va_dpy);

        pmfxDEC = new MFXVideoDECODE(mfxSession);

......

libva info: VA-API version 0.34.0
open lib: Invalid argument
libva info: va_getDriverName() returns 1
Segmentation fault (core dumped)

i don't known how solve ?

i'm english very poor.

 

 

 

4 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

it must root ?

There can be many causes for errors starting Media SDK.  Quite often these can be traced to installation.

Which processor are you running on, which Linux distribution, and which release of Media SDK for Linux?

Here is a quick checklist for installation:

1) Verify that the processor is supported (chipset too for Xeon).  Supported configuration requirements in the release notes are very specific.
2) Verify supported kernel level (in release notes)
3) Check that Intel integrated graphics is available with '$ lspci -nn | grep "VGA" '
4) Remove all versions of libdrm before installing 
5) after install, check that the i915 module loaded with '$ lsmod | grep i915'
6) Verify that the user running the Media SDK application is in the 'video' group

If there are problems running as a regular user, running as root may often help.  There are still some issues with running multiple sessions where running as root is a workaround. 

Regards, 

Jeff

 

 

 

 

thanks u reply!

[zhaoya@localhost intel-linux-media_sles_16.3.15249_64bit]$ ./install_media.sh
Error... You are about to install on a non supported linux distribution.

INFO... Install on CentOS ...
Error... This script must be run as root!

i install sucess by root.

[zhaoya@localhost intel-linux-media_sles_16.3.15249_64bit]$ uname -a
Linux localhost.localdomain 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[zhaoya@localhost intel-linux-media_sles_16.3.15249_64bit]$ lspci -nn | grep "VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09)
[zhaoya@localhost intel-linux-media_sles_16.3.15249_64bit]$ lsmod | grep i915
i915                  537538  2
drm_kms_helper         40087  1 i915
drm                   265638  3 i915,drm_kms_helper
i2c_algo_bit            5935  1 i915
i2c_core               31084  5 i2c_i801,i915,drm_kms_helper,drm,i2c_algo_bit
video                  20674  1 i915
[zhaoya@localhost intel-linux-media_sles_16.3.15249_64bit]$

gopher:x:30:
video:x:39:zhaoya

 

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui