No luck with debugging OpenCL kernels using VC2013

No luck with debugging OpenCL kernels using VC2013

Hello,

I would like to debug my opencl kernel using the opencl debugger plugin within VC2012 (+ Intel SDK for OpenCL Applications 2013 3.0.0.81147; Intel SDK for OpenCL - CPU Only Runtime Package 3.0.1.15216).

Here is what I did:

1. Called clBuildProgram with additional options, as mentioned in the documentation:
    clBuildProgram(program, 1, &device, "-g -s C:\\PathToMy\\File.cl", NULL, NULL)
2. Enabled the OpenCL debugger, told it to trigger at Dim 0/0/0
3. Started debugging. VC2012 seems to halt, but I can't do any actual debugging.

I've recorded a short screencast (at least 720p is adviseable): http://www.youtube.com/watch?v=f4lDWrBbLXE

I would be grateful for any idea what is going wrong here.

Thank you in advance, Clemens

3 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

We are debugging an issue where some users are not able to debug their kernels. I will post here when there is new information.

Thanks,
Raghu
 

Can you generate the debug log and attach that here. Set the environment variables

INTEL_OCL_DBG_LOG=1
INTEL_OCL_DBG_LOG_FILE=c:\temp\debugger.txt

and launch Visual Studio. Continue debugging and you should see the debug log under c:\temp.

Thanks,
Raghu

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui