How can I install Intel fortran compiler 9.x on my Ubuntu machine?

How can I install Intel fortran compiler 9.x on my Ubuntu machine?

Hi,

 

I need to run older version of Intel Fortran compiler on my Ubuntu 10.10 so that some old style Fortran 77 code can be built.

 

I've already got a Serial number from the registration center. Unfortunately, this serial number doesn't work for Intel visual fortran composer 9.0, though it works well for the latest version of Intel Fortran composer XE.

 

After entering the serial number, the error message is given as follows,

 

"

 

Please type your selection or Serial Number  :   XXXX-XXXXXXXX-

 

Setup may attempt to connect to the Intel(R) Registration Center to validate your Serial Number.

This may take several minutes depending on your network.  Please wait...

You may press Ctrl+C to cancel.

 

======================================================================

Invalid Serial Number:

You entered an invalid serial number

The Intel Software Setup Assistant could not confirm your serial number.

Your serial number can be found in either of the following locations.

    * Email confirmation regarding your purchase or evaluation.

      This email also includes links to download the product.

    * Inside product packaging. A label is affixed to the inside of the

      CD case that includes the name of the product and your serial number.

 

If you cannot find your serial number or do not have a serial number for

Intel(R) Fortran Compiler 9.0 for Linux*, you can visit Intel's Technical Support at:

    "https://registrationcenter.intel.com/support/"

 

I wondered if this problem could be solved by using a license file. So I tried to generate a license file on the Intel registration center according to this  article "https://software.intel.com/en-us/articles/older-version-installation".

However, no valid link was found on that page.

 

Could you please tell me how to fix this problem?

 

Many thanks,

 

Charlie Shao

6 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

You could use the license file from your working newer installation or click on the license shown when you are downloading to have a copy emailed to you.

Thank you TimP.

 

Actually, I have tried to use the license file generated for the working newer installation located at /opt/intel/licenses/

 

however, after entering the license path, I was prompted that the license file is invalid. the error message is given as follows

 

===============================================================================

Invalid license file

 

Please make sure that the file you provided at /opt/intel/licenses/l_XXXXXXXX.lic is a valid license file with active support for the Intel(R) product you are trying to install. If you are installing on a native-language system other than English, please make sure that the full path to the license file uses only English characters.

 

===============================================================================

 

An alternative way is to enter the serial number, but it did not work either. The installer prompted the error message

 

Please type a selection or Serial Number:   1

Enter Serial Number:   XXXX-XXXXXXXX

 

The  Intel(R) Software Setup Assistant  may  attempt to  connect  to the

Intel(R) Registration Center to validate your Serial Number.This may take several minutes depending on your network.  Please wait...

 

You may press Ctrl+C to cancel.

secore: relocation error: /lib32/libresolv.so.2: symbol strlen, version

GLIBC_2.0 not defined in file libc.so.6 with link time reference

 

 

By the way, I did not find any downloadable license files when downloading the compiler or receive any license in the email form the registration center.

 

the version I used is Intel fortran compiler 9.1.052.

 

Can you guys provide any other solutions?

You would need to add the older 32-bit libraries with glibc2 support, according to that message.  Assuming that your license covers linux ifort, this may be the reason it's not recognized.

I'm not current on Ubuntu; there used to be 32-bit libraries to support older gcc versions.  Ubuntu was not supported for the 9.1 compiler, so you may face additional difficulties.

The main problem is that we have changed the license file components since then, so older products will no longer work with current license files or serial numbers.  But I think the better question is why isn't the current compiler working correctly?  I recommend getting that resolved if possible.  You can ask that question over at the Intel® Fortran Compiler for Linux* and Mac OS X* forum.  If that can't be resolved, then we'll pursue the license further.

Thank you James Tullos. 

The reason why I chose to use older version of Intel compiler is because I found that the f77 code I got from my colleague was only compatible with Compaq Visual Fortran 6.X . I thought that a closer successor to the CVF6.x  might be a reasonable choice.

Now I find that the installation of IVF9.x on ubuntu or other linux distro is almost impossible since both software package and license are no longer supported.

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui