Inspector "Error detected during analysis" when Detect Memory Problems

Inspector "Error detected during analysis" when Detect Memory Problems

Hi, 

Today when I run inspector to analysis my project, I met this error.

Before I had not ever met this error.

I had try to reinstall inspector, bug not fixed the problem, and even the whole c_studio_xe_2013_sp1_update2_setup.

I am sure I don't run any defense software.

I have license for  c_studio_xe_2013_sp1_update2_setup

Additionally, my project can run smoothly when not analysis with inspector.

 

My Inspector version is : 

Intel® Inspector XE 2013 update 9

VS version is:

Microsoft Visual C++ 2010

OS version is:

Windows 7

 

The following is the screenshot

 

8 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

Send me the affected result directory in a private message.

Hi, I have the same problem; every Visual Studio 2010 project I try to analyse, Inspector end quickly after the init of executable with this error.

Can you help me?

Was it possible that this was due to no enough memory to work when Inspector ran?

Did you build 32bit application but running in 64bit system? If so, please use option "/LARGEADDRESSAWARE" to build your 32bit app.

Can you try this in Inspector standalone app (inspxe-gui), or command line (insplxe-cl) ?

Can you set stack-depth=1 to reduce memory consumption from Inspector's monitoring? Or set option "-module-filter-mode=include -module-filter=your-program" for your target module only?

Citation :

Peter Wang (Intel) a écrit :

Was it possible that this was due to no enough memory to work when Inspector ran?

Did you build 32bit application but running in 64bit system? If so, please use option "/LARGEADDRESSAWARE" to build your 32bit app.

Can you try this in Inspector standalone app (inspxe-gui), or command line (insplxe-cl) ?

Can you set stack-depth=1 to reduce memory consumption from Inspector's monitoring? Or set option "-module-filter-mode=include -module-filter=your-program" for your target module only?

I think that 's no memory problem, but I tried both 32-bit and 64-bit debug version of my application to obtain same result ( I noticed that in 64-bit version the error occurs before than in 32-bit version). I tried many combination of 32/64 bit, using "/LARGEADDRESSAWARE" for 32 bit, running with VisualStudio plugin or with the standalone GUI, stack-depth of 1 or 8, reducing the number of modules checked, but no changes (at last trial I have memory usage of 455 MB).

Searching in the data folder (ok maybe I don't have to look around in these folders?) I found a pin_error.log file
 

<?xml version="1.0" encoding="utf-8" ?>
<!--  DO NOT EDIT THIS FILE -->
<log version="2.0" source="pin">
<msg id="1">
<type>2</type>
<description>Source\pin\vm_ia32\jit_region_ia32.cpp:LEVEL_VM::REGION::XlateControlFlow:LEVEL_VM::REGION::XlateControlFlow:2464: assertion failed: INS_HasFallThrough(ins) </description>
<severity>ERROR</severity>
<timestamp>Thu Jun 12 09:35:23 2014 </timestamp>
<pinversion>2.12</pinversion>
<kitnumber>61147</kitnumber>
</msg>
</log>

 

this may help you?

Mark may understand pin log better. Have you sent result directory to Mark?

Sending problematical application to Mark, also will be helpful, I think, if possible.

Citation :

Peter Wang (Intel) a écrit :

Mark may understand pin log better. Have you sent result directory to Mark?

Sending problematical application to Mark, also will be helpful, I think, if possible.

Thanks Peter, I haven't sent to Mark the Inspector analysis folder because he didn't ask me (I don't want to be pushy and send messages without permission).

I cannot send the application because is a commercial application under licence, I'm sorry.

Still have other thing to try, in command line:

inspxe-cl -collect mi2 -r /tmp/r000mi -module-filter-mode=include -module-filter=your-module -- ./your-app

Will you see same result? Or application exits abnormally?

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui