automatic offload cpu usage

automatic offload cpu usage

Dear all,

I found AO DGEMM use only one CPU core for "CPU fraction", although OMP_NUM_THREADS=4, and MKL_NUM_THREADS=4. When I set MKL_MIC_MAX_MEMORY=1024, AO don't use MIC, only one CPU core, although MKL_MIC_WORKDIVISION=1.0. (Matrix dimension: 6232)

 

(composer_xe_2013_sp1.2.144)

 

3 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.

MKL runtime scales down the number of cores to use when it believes using more cores or threads won't help performance. To disable this feature and force it to always respect MKL_NUM_THREADS or OMP_NUM_THREADS, you can set MKL_DYNAMIC=0.

MKL_MIC_MAX_MEMORY=1024 means 1024K bytes of memory reserved on MIC for automatic offload. This value is too small. Try set it to 1024M, or 1G.

Thank you! That's working.

Laisser un commentaire

Veuillez ouvrir une session pour ajouter un commentaire. Pas encore membre ? Rejoignez-nous dès aujourd’hui