can't startup HAXM emulator on windows 8.1

can't startup HAXM emulator on windows 8.1

Keep on getting this error message. 

emulator: Failed to sync vcpu reg

emulator: Failed to sync HAX vcpu context

 

I have confirmed so many times that my cpu vt is work well. I have searched a lot about this error, but haven't got solution, please help!!!

12 posts / 0 nouveau(x)
Dernière contribution
Reportez-vous à notre Notice d'optimisation pour plus d'informations sur les choix et l'optimisation des performances dans les produits logiciels Intel.
Portrait de Alexander Weggerle (Intel)

Hi,

do you have any other software running making use of Virtualization Technologies? Most likely this is the cause. 

Let me know if it worked!

Alex

Hi Alexander

Thank you for your reply. I have the same idea as you. My computer have vmware installed.

The problem is I don't want to uninstall it. I tried to stop all services and threads about vmware in my machine, but still not working. Is there any way to find out what software is using VT?

Portrait de Alexander Weggerle (Intel)

Hi,

unfortunately I'm not aware of a possibility to check this. Maybe you can try to disable the VMWare Services and do a reboot to check if vmware was really the root cause. Meanwhile I will ask around if we ever encountered this issue before. 

Thanks,

Alex

You could go to where you would add Microsoft Hyper-V (Turn on /off Windows Features in Programs ) - if it's grayed out, something is being seen as a VM.
You might look at http://oxfordsbsguy.com/2013/08/01/how-to-enable-hyper-v-on-windows-8-1-.... - 
Not that you want to enable hyper-v, but if you use those vmware changes it MIGHT allow it not to be seen?

Just a thought.

Citation :

Colleen Culbertson (Intel) a écrit :

You could go to where you would add Microsoft Hyper-V (Turn on /off Windows Features in Programs ) - if it's grayed out, something is being seen as a VM.

You might look at http://oxfordsbsguy.com/2013/08/01/how-to-enable-hyper-v-on-windows-8-1-.... - 

Not that you want to enable hyper-v, but if you use those vmware changes it MIGHT allow it not to be seen?

Just a thought.

Hi,

That's an interesting thought. I didn't know windows in vm could enable hyper-v before.

I can understand your idea, maybe if I disable the vt-x feature in vm could make some difference. But unfortunately, no. 

BTW: My hyper-v option is not gray, in fact, it should be disabled to release the vt feature for other virtual machines, such like vmware or android emulator. 

Citation :

Alexander Weggerle (Intel) a écrit :

Hi,

unfortunately I'm not aware of a possibility to check this. Maybe you can try to disable the VMWare Services and do a reboot to check if vmware was really the root cause. Meanwhile I will ask around if we ever encountered this issue before. 

Thanks,

Alex

Hi Alex,

Thank you for your help. I have tried to disable services about vmware and restart my computer. Noting changed.

I'm not sure if all relevant services had been stoped. Or the problem isn't lay on vmware at all.

Here are some more details about my computer:

  • Lenovo Idea Pad Y580
  • Windows 8.1 x64 pro installed on SSD drive.
  • Java 1.7 x86
  • android-sdk & HAXM driver up-to-date
  • vmware installed & hyper-v disabled

Thanks 

Portrait de Alexander Weggerle (Intel)

Hi,

which version of VMware do you have installed? We want try to reproduce the issue...

We once had a similar issue on OS X where it helped to reinstall the virtualization software... Maybe this helps for your issue as well?

Thanks,
Alex

Hi,

My vmware version is 10.0.3. I'm so glad to hear there may be a solution. :)

Portrait de Alexander Weggerle (Intel)

Hi, 

we tried to reproduce this with the same software configuration you having and it worked perfectly. 

Can you try to reinstall HAXM manually from our website and reinstall VMWare?

I would also try to disable any anti virus scanner for a quick test (and don't forget to enable them later again). 

Alex

Hi Alex,

Thank you so much for all your help. I have solved my problem. But not with your solution.

It's my fault that I lost the detail which was I ran x64 Java on my machine. After I reinstalled the x86 java, everything works well. I thought the android emulator had noting to do with java environment, which turns out to be false.

BTW, I have uninstalled VMWare and reinstall HAXM from your website, just as your description. But failed to start emulator either. After that I tried to reinstall java and found the final solution. So I still don't know weather just reinstall java will work. Some one else have the same error could try it.

Again, Thank you Alex and also thanks to Colleen. :)

Portrait de Alexander Weggerle (Intel)

Hi, 

great to hear that it works now for you! Strange that the installation of x86 Java solved it. Never heard this solution before. You learn everyday something new :-)

Alex

Connectez-vous pour laisser un commentaire.