Intel® Parallel Amplifier

NVD3DUM Eating CPU Cycles

I've been doing a little profiling work on my games engine and have noticed that an inordinate amount of time can be spent inside the NVD3DUM.DLL module, and VTune reports up to 50% of my CPU workload happens inside.  For now I have resigned to accept that this is probably the driver handling the preparation and submission of my graphics data to the GPU but that's just a guess, and trying to find information about this module is pretty tough with almost no information on it.

VTune causes unknown NMIs and sometimes seg faults

We're running VTune on a 256 core SGI Linux machine.

 

In the syslog, we get the following messages when I start VTune:

 

Kernel : vtss_cmd_start[cpu98]: starting vtss++ collection

Kernel:  vtss_cmd_start[cpu98]: starting vtss++ collection continue 1

Kernel: vtss_cmd_start[cpu96]: starting vtss++ collection continue 10

…then all the errors spew out….

Kernel: uhhuh. NMI received for unknown reason 00 on CPU 74

Kernel: do you have a strange power saving mode enabled?

Can't find CLI_install folder

As part of the release note, release_notes_amplifier_linux.pdf, on page 7, it says:

"Copy the CLI_install folder (found at the top level in the extracted product install package) to the remote machine..."

My problem is that before or after install, the CLI_install folder is nowhere on my file system.

Can someone point me to a location where I can download the CLI_install folder or how to otherwise generate it?

Thank you!

Problem when importing files to result folder

Hi,

I'm trying to import the trace files collected using SEP tool in vtune.

I use the below command

C:\Users\pyn>amplxe-cl -import ToS_720p_29.97ps_H264_4000kbps_NOAUD_4min_R3.tb6 -result-dir=C:\SepDataCollectio\nodiSwamyProject\TOS_1C1T_720p304

I get the Below error:

amplxe: Error: 0x40000007 (Not found) -- C:\SepDataCollectio\nodiSwamyProject\TOS_1C1T_720p304

Anyone know the solution to resolve?

 

vtuen assert failed

Hi all,

    I used vtune to attach to target pid, and I used same user, but got error:

amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /home/work/vtune/r002hs -command stop.

amplxe: Error: [Instrumentation Engine]: Source/pin/pin/image.cpp:RTN_Sec:RTN_Sec:511: assertion failed: RTN_Valid(x)

amplxe: Collection detached.

amplxe: Internal Error

Can anyone met this and give some suggestions?

VTune reports Haswell server as unsupported architecture

We are able to perform basic sampling under Windows 2012 on an E5-2699 v3 Haswell server. When we try to set up a General Exploration analysis it displays the window for a fraction of a second where it is determining architecture, then reports "unsupported architecture." If we start the VTune run, it quits immediately. Amplifier XE 2015 build 367959, Evaluation installation
Execution engine is CPlex. We don't expect to view source code, simply hoping to evaluate whether cache behavior is a bottleneck.

How to measure FLOPS using vTunes?

I have a problem understanding some of the counters reported by vTunes XE 2013 in order to calculate FLOPS according to this Intel article. Using the vTunes counters I get approximately 3 times as high values than the manually counter value (and it should not be due to speculation I think). Here’s the details of this:

General Exploration

Hello,

I am using Intel Vtune Amplifier XE 2013 on my windows 8 laptop powered by,Intel 4th gen-i5 with 6GB RAM.

I run matrix multiplication in VTune tool,by both the method,

1.Normal Matrix Multiplication

2.Loop Interchange.

now I want to calculate some quantities,but I am not able to find it anywhere inside the tool.

  1. MEM_LOAD-UOPS-RETIRED.L2 MISS
  2. MEM_LOAD-UOPS-RETIRED.LLC MISS
  3. .L2_RQSTS.PF_MISS
  4.  CYCLE_ACTIVITY.STALL_CYCLES_L2_PENDING

 

 

VTune™ Amplifier XE remote collection using Windows* Host

Hi, I'm tying to use VTune™ Amplifier XE 2015 (on Windows7) to analyze my program running on linux remotely. And I follewed steps here: https://software.intel.com/en-us/node/506493. But I get some problem when I get to step 8:lick the New Analysis button to choose an analysis type for your remote collection.After I clicked the New Analysis button,it says something like this:

    Detecting remote machine configuration

S’abonner à Intel® Parallel Amplifier