Intel® Inspector XE



I am trying to run:

mpirun -np 2 inspxe-cl --result-dir insp_results -collect mi1 -- myApp

but i get the following error:

Fatal error: Cannot start collection because the Intel Inspector XE 2013 failed to create a result directory. Unknown error

This message comes only once, if I start 3 jobs 2 times, 4 jobs 3 times, etc.

inspector create only one directory insp_results, so without numbers.

What is going wrong?

best regards,


Inspector using gigabytes


I downloaded an evaluation version of Intel Inspector 2015 for Linux. I tried testing it on a small program but the memory usage went up to 25GB until I killed it. I then just compiled the program below:

#include <stdio.h>

   int a, b;

   a = 1;
   b = a;
   printf("b= %d\n",b);
   return 0;

In other words, the program is tiny just to test Inspector itself. I'm running Inspector from the command line using

Command line: There is no disk in the drive.


I'm trying to run Inspector from the command line. I have it working fine inside Visual Studio. I click on "Command Line...", copy the command to the clipboard, and run it exactly as is.

I get an error that says "There is no disk in the drive. Please insert a disk into drive \Device\Harddisk3\DR3."

Can anybody help me resolve this issue?

Here's my batch command line exactly as copied from the clipboard:

Understand Intel Inspector output

Dear Intel Inspector users,

I'm using for the first time this tool to analyze some possible data race in my mixed Fortran/C and OpenMP code. My tools is from intel cs 2013 package. By using the interface on a little run, Inspector detect some data race problem. Analyzing the report, are reported in each data race the source line where should be. The strange thing is that Inspector report a data race in the line where I define the subroutine, not in the body of the function. For example:

Fortran Memory not deallocated - Inspector indicates subroutine declaration

I am having trouble understand this error, and I figure that it must be a false positive. Using Inspector, I cleaned up a number of Memory not deallocated errors where the allocatable variables were in a module that persists through the life of the application.

However, I have one memory not deallocated error remaining, and I figure that this must be a false positive.

How to analyze a C# ASMX web service?

I only have Inspector XE 2013 installed and use Visual Studio for an IDE.

When I start the web service DLL in the Visual Studio debugger, it fires up WebDev.WebServer40.exe to actually test it.

Is there a way to threading and memory analysis on a VS2010 ASMX web service (.NET 4.0)?  if so how is this done?



Any success stories with memory leak detection in Fortran 2003/2008 code with allocatable components?


Has anyone have been able to successfully use Intel Inspector on Fortran 2003/2008 code that makes use of Fortran ALLOCATABLE constructs (dynamically allocatable variables of intrinsic or derived type, derived types with allocatable components, etc.)?

As you may know, Fortran standard offers protection against memory leaks with the use of ALLOCATABLE constructs e.g., automatic deallocation of variables with local scope upon procedure termination, thereby coders can rest assure certain standard-compliant code can be free of leaks.

How to understand 'Mismatched allocation/deallocation'?

Dear all,

I have the following code:


  idx2faclist = new int[points->items + 1];


  delete [] idx2faclist;


The Intel Inspector gives me 'Mismatched allocation/deallocation' error message for the line

  idx2faclist = new int[points->items + 1];


  delete [] idx2faclist;


How to understand this error message? How to modify the code to remove this error message?



Zhanghong Tang

How to understand 'Uninitialized memory access'?

Dear all,

I have the following code:


    node *node3=new node[npoint];
    for (int i=0;i<npoint;i++)


The Intel Inspector tells me the 'Uninitialized memory access' error at line

    node *node3=new node[npoint];

and qsort function.

Inspector does not let my program read external files.

I have a program that must read a configuration file when it starts but whenever I start this program inside inspector the program does not read this external configuration file. If I execute the program outside of Inspector the program loads this file fine.

Is these something I can do so that my program reads the config file?


S’abonner à Intel® Inspector XE