Media

is there a low-end product that only supports HEVC decoding?

Hello,

Now we only need a light version similar to intel media sdk 2014 r2, to support HEVC decoding.  However, the intel media server studio is way too big and expensive. In order to include HEVC codec, the professional version is required. Will intel have a light  version only to support HEVC codec (decoding or encoding) in the near future?

Thanks.

 

 

Audio Encoder returns MFX_ERR_INVALID_HANDLE

When attempting to initialize the audio path encoder I get MFX_ERR_INVALID_HANDLE error.

Logic used:

mfxVersion SWversion = {0,1}, HWversion = {0,1}, version;

mfxSession Audiosession;

mfxStatus sts;

sts = MFXInit(MFX_IMPL_AUDIO | MFX_IMPL_SOFTWARE, &SWversion, &Audiosession);

if (MFX_ERR_NONE == sts){

MFXQueryVersion(Audiosession,&version);

printf("Audio version:%d.%d API Level: %d.%d\n",

SWversion.Major,SWversion.Minor,

version.Major, version.Minor);

mfxIMPL implTest = 0;

Maximum MFXVideoDecode instance number

Hi All,

Now I'm trying to use Intel media SDK. So, I have checked the performance and limitations.

Using "sample_decode" sample(64bit build), I try to create multiple instance to know limitation as below.

CDecodingPipeline Pipeline[128];

for ( int i = 0; i < 128; i++){

     Pipeline[i].Init(&Params);

}

for(int i=0; i<128; i++){

     Pipeline[i].ResetDevice();

     Pipeline[i].Close();

}

Android Camera Streaming

My app is based on the Camera Streaming sample code. I am seeing low frame rates while streaming (my test device is  4.4). Before streaming the preview looks like it's full frame rate (> 24fps). Once i start the capture it drops to 3-4 fps for the preview and the stream to Wowza. I have disabled all effects in the pipeline. The CPU shows 36% idle. Any thoughts?

HW decoding memory leak

My program uses a pool of switchable video decoders. So I do a lot of these calls:

  MFXVideoDECODE_Init (..)
  MFXVideoDECODE_DecodeFrameAsync (..)
  MFXVideoDECODE_Close (..)

Running in software mode, everything is fine. Running with MFX_IMPL_HARDWARE_ANY init flag will result in a lost of about 30 MB per Init/Close call. This occurs only when decoding frame data. Just initializing and closing decoder seems to produce no leak.

VPP problem with resize and letterbox

Hi there,

I wrote my application referencing both simple_5_transcode_opaque_async_vppresize and sample_multi_transcode. It turned out when I do VPP resize and letterboxing, the video is not letterboxed.

The strange part is that when I added the ResizeAndLetterBox routine to sample_multi_transcode, it WORKS! But, when I added the same ResizeAndLetterBox routine to simple_5_transcode_opaque_async_vppresize app, it DOESN'T WORK!

S’abonner à Media