Havok

Naming Animations

Hi.

We are using Maya 8.5 and the Havok exporter.

The Animation Container class in Havok has a function FindSkeletonByName, but I see no FindAnimationBindingByName. I've looked at the documentation on the hkaAnimationBinding class and there doesn't seem to be any way to name animations.

We need to be able to name our animations so that we can use the right animation for the right skeleton. Does anyone know of a way to do this, and then obtain the animation name in code?

Forums will be read-only 09/24 10PM PST to 09/25 12PM PST

Hello,

From Tuesday, September 24, 10pm PST to Thursday, September 25, 12pm PST, the Intel Software Network Community Forums will be read only in preparation for the new forums interface launch on Thursday, September 25. During this time, users will be able to read the forums, but will not be able to reply or submit new topics. The new forums will have an improved look and many added features. We hope youll like the new ISN Community Forums.

Warm regards,

character falling from rigid body

I created a character and placed it on top of an animated rigid body (cube shape). Both have friction = 1.0, and the rigid body is animated at a slow velocity using setHardKeyFrame. The problem is that once the rigid body stops, the character immediately falls off the cube. Changing the friction does not impact the result. What can I do to ensure the character stay on the cube until I specifically move it manually?

Two rigidbodies not colliding properly

Has anyone experienced this problem before?

- Using autodesk maya to create 2 meshes. A box and a sphere. Sphere is a moving body falling onto the box.

- Exported to .hkx using havok content tools. *Note transform scene was set to use SCALE_FEET_XXX

- Confirmed with preview scene that sphere falls until it hits the box.

- Loaded hkx unto the graphics engine

- Sphere falls and collides somewhere in mid-air and does not seem to reach the box

~hkArray() error

I have this error in my engine, so, i've done a simple example, and i alsow get it. Example is next:

I have main.cpp with code:

#include "HavokTestFramework.h"

boost::shared_ptr htf;

void main()

{

htf = boost::shared_ptr(new HavokTestFramework());

}

and HavokTestFramework.h:

class HavokTestFramework

{

public:

HavokTestFramework();

~HavokTestFramework();

Does the tryHavok version works for windows xp?

Hi everyone, i have been trying to make run a simple demo with havok, i can compile it successfully, but when i run it i got this message:

"This application has failed to start because the application configuration is incorrect. Review the manifest file for posible errors. Reinstalling the app... "

The reason of this error could be that im using win XP?... because this demo is tested under vista.

Thanks a lot for any help.

S’abonner à Havok