Intel ISA Extensions

SDE emulation issue

I am using the SDE emulator with AVX2 instruction set, I have written some simple program but it is crashing in RELEASE mode with SDE emulator.

Please let me know whether SDE emulates the stack related operations or not.  YASM synatxed assembly programming

section .txt
 global dummy_asm
    dummy_asm:

    push rbp
    mov  rbp, rsp
    sub rsp, 1024
    
    push rbx ;no need to push in this program, but in actual program using this register
    
    vmovdqu [rsp], xmm0 ;xmm0 is dummy value

    pop rbx

Broken links for MPX GCC version on the Intel server?

I'm not sure where else to post issues with downloads so I'm just posting it here. At the following URL https://software.intel.com/en-us/articles/intel-software-development-emu... I'm trying to download the patched version of GCC. The download, however, stops before it is finished. I have tried to download these files from different physical systems, using e.g. Firefox and wget; just to exclude issues on my side. Is there any more recent static version of GCC with MPX available?

AVX _mm256_store_ps

Hi

I am wanting to run the following code using the AVX instruction set,

 I compile without any problem but generates an error when I run:

./vec_avx.x 

"Segmentation fault (core dumped)"

Reviewing the code the problem is in the instruction: 

  _mm256_store_ps(&total,acc); //Error

Could someone point me to to be.

Thank you

pd:

I compile with the following command: 

gcc -O3 vec_avx.c -mavx -o vec_avx.x

And the main code is as follows:

Intel MPX, unable to reproduce results in example

In trying to reproduce the example given by Ady Tal at https://software.intel.com/en-us/articles/debugging-applications-with-in... I encounter the following problem:

Terminal 1:

$ ../sde-external-6.22.0-2014-03-06-lin/sde64 -mpx-mode -debug -- ./mpx_test3
Application stopped until continued from debugger.
Start GDB, then issue this command at the (gdb) prompt:
  target remote :44736

Terminal 2:

SIGILL on AVX instruction

Hi,

I have a very simple test program that I'm using to play around with AVX instruction sets. It works perfectly fine on my MacBook Pro, however, the same piece of code will fire off a SIGILL on my Linux workstation. I check cpuid before invoking the instructions and /proc/cpuinfo is also has the AVX flag set. I'm using clang with the -mavx command line switch. The instructions throwing the exception are any _mm256_xxx ones. I'm not using the FMA instructions. /proc/cpuinfo says I have 12 cores of Intel(R) Xeon(R) CPU E5-1660 0 @ 3.30GHz.

TIA,

Irfan.

help with 1073741819

hi, i don't know it i am posting on the correct position of forum (i'm not an expert), anyway 

i'm using a proprietary software that give me an error on an executable file, the error say this: "aborted with system error code 1073741819".

the assistance of this software say me that is a bug that comes up when i execute it on intel 4th generation processor

they say also that the  workaround is to rename the file mkl_avx2.dll to this: mkl_avx2.dll.11.0.0.1 

but for me it doesn't work, maybe because i'm using an 3th generation processor (i7 3610QM) 

 

Bug in SDE emulation of AVX-512 _mm512_permutevar_ps() ?

Hello,

I have an issue with SDE emulating _mm512_permutevar_ps() [aka VPERMPS] in an unexpected way. I understand from the documentation that it should behave as the 512 bit variants of _mm256_permutevar8x32_ps(), and be able to do cross-lane shuffling. So the attached file should reverse the content of the vector. It works with _mm256_permutevar8x32_ps(), but _mm512_permutevar_ps() clearly doesn't produce the expected results, but rather an intra-lane shuffling:

asm blocks

Hello,

I am writing AVX code inside asm blocks (don"t want to use avx intrinsics).

A lot of gp registers are used and so they are mixed with the ones generated by the compiler and thus it is screwing the behavior of the code pretty fast.

Is there an automatic or manual way to avoid these register overlaps ?

Any link to documentation would be great.

I would like also to use asm blocks in fortan with ifort, but didn't find the way yet.

Thanks

Vincent

SDE produces unstable behavior

Hi,

I have some SSE/AVX code that I'm trying to test with Intel Software Development Emulator (SDE) on CPUs without the native support for some of the instruction set extensions. In particular, I tried the following setups:

1. Sandy Bridge CPU, SDE is running with -hsw switch.

2. Sandy Bridge CPU, SDE is running with -hsw -sse-sde switches.

3. A KVM guest virtual machine with SSE4 instructions (host CPU is Nehalem), SDE is running with -hsw switch.

All this is on Linux x86_64, SDE 6.22 and 6.12.

S’abonner à Intel ISA Extensions