ld: warning: -macosx_version_min not specificed, assuming 10.6

ld: warning: -macosx_version_min not specificed, assuming 10.6

Dear all,I got the warning message on my new mac (os X 10.6.8). The ifort version is 11.1 20100203How to get rid of the warning message, ld: warning: -macosx_version_min not specificed, assuming 10.6?Thanks,Michael

6 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

That version of the compiler is not supported on OS X 10.6.8. Please update to the current 12.0.4.

Steve - Intel Developer Support

You did not say what Xcode version you are using. Since this is an older 11.1 compiler, make sure you are using the older Xcode 3.2.5 version. We have seen this message when older compilers are run with newer Xcode 4:

http://software.intel.com/en-us/forums/showthread.php?t=81437&o=a&s=lr

It is Xcode 4. Thanks Ronald.

Hi there, I have Xcode 3.2.6, ifort version 12.0.3 on mac os 10.6.8. I have bought the student edition of ifort but there is ld warning showing whenever I compile my fortran90 codes by ifort. It reads

"ld: warning: -macosx_version_min not specificed, assuming 10.6"

My question to the Intel guys is: Can I get an older version of ifort ( intel fortran compiler for Mac OS ) instead of this (ifort 12.0.3) if there is some compatibility issues with the updates?
Waiting for you reply.

Thank.

Yes, older versions can be obtained.  Here is the article describing this:  http://software.intel.com/en-us/articles/older-version-product

It is important to carefully match Mac OS version to Xcode version to Intel Fortran compiler version.  Here's how - Release Notes.  Read the Requirements in the Release Notes.  Using Intel Registration Center, find your version of the Intel Fotran compiler.  In the downloads, you will find the Release Notes that can be downloaded separately.  Read the Requirements to make sure it matches your system's OS X and Xcode versions.

ron

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi