Is there very simple ScaLapack sample like "Hello World" ?

Is there very simple ScaLapack sample like "Hello World" ?


I wrote simple test program like HelloWorld of ScaLapack, then tried to compile withwith MKL 10.3 (C++ Composer XE-2011)
but unknown link error occurred.

ipo: warning #11021: unresolved symbol: for_write_seq_fmt
1> Referenced in mkl_scalapack_lp64.lib(pxerbla.obj)
1>ipo: warning #11021: unresolved symbol: for_write_seq_fmt_xmit
1> Referenced in mkl_scalapack_lp64.lib(pxerbla.obj)

link libraries are:
mkl_core.lib mkl_intel_lp64.lib mkl_intel_thread.lib mkl_blas95_lp64.lib mkl_lapack95_lp64.lib mkl_scalapack_lp64.lib mkl_blacs_mpich2_lp64.lib libiomp5md.lib mpi.lib cxx.lib

Seems mkl_scalapack_lp64.lib uses for_write_seq_fmt funciton, but I cannot found out which library contains this symbol.

my question is:
[1] how to avoid link error using ScaLapack on MKL?
[2] Is there any sample code of ScaLapack on MKL?

Thanks in advance

5 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

for linking - pls use MKL Linker Adviser.for example - you can find some examples into \examples\pblasc.

Thanks for reply.

I tried both MKL Linker Adviser and exmplaes you mentioned.

I used output of MKL Linker Adviser, but results was same.
(still causes link error)

Also, I tried to compleexamples/pblasc like following, but seems that it needs fortran compiler (ifort)

C:\tmp\scalapack>nmake arch=intel64 mpi=mpich2 mpidir=C:\MPICH2 libdir="c:\Program Files (x86)\intel\ComposerXE-2011\mkl" libtype=static exe

I installed MPICH2 on C:\MPICH2 directory and it works with no problem.
then, nmake stopped with following error message:


Microsoft Program Maintenance Utility Version 6.00.9782.0

Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

if not exist "obj_intel64_static_mpich2_lp64" mkdir "obj_intel64_static_mpich2_lp64"

ifort /c /O3 /w .\psludriver.f /object:obj_intel64_static_mpich2_lp64\psludriver.obj
(here reports error like "cannot found ifort")

I bought C/C++ version of Compose XE-2011. (no fortran compiler included version)

this means to compile those example,it needs ifort.Am I wrong?
(Actually, the subdirectories under examples/pblasc directory, there are lots of .f files)


> (Actually, the subdirectories under examples/pblasc directory, there are lots of .f files)

Sorry. I got confused.

there was no .f files under mkl/examples/pblasc/source directory.
(the above .f I mentioned is under mkl/tests/scalapack directory)

I'll try pblasc exmple.


Once I uninstalled ComposerXE 2011, then re-installed latest version (ComposerXE 2011, update 11),
everythings work with no problem. (link error disappeared)

and also pblasc example has successfully compiled and executed.



Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi