VTune locks up PC making it extremely hard to use.

VTune locks up PC making it extremely hard to use.

I am profiling 'cooking' for Unreal Engine 3 (as a licensee) using Amplifier XE 2011 (build 206420) and it frequently locks up (using 100% CPU for COre i7 3.2GHz PC) during review of the results from a Hotspots profile. This makes it basically impossible to use most of the time... which is ashame as its exactly the type of information I want to see.Is there any update that can reduce CPU usage when reviewing Hotspots data collections?Is there anyway to disable features. Note that it seems to spend alot of time constructing the critical path stack trace over on the right side even though I don't care about it. THere doesn't seem to be any way to remove this feature from hotspots though.What I really want is to open up the main treeview (top-down) of profiling results and see where the time is going.Note this super lag doesn't seem to happen if I profile Light Hotspots.Any help appreciated.-Adam.

2 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Hi Adam,You can customize Hotspots by right-clicking on "Hotspots" -> select "Copy from Current" to create new one, then modify default settings of Hotspots.Reduce overheads:1. Enlarge "CPU sampling interval" value, reduce samples2. Unselect "Detect context switches"3. Use "Without stacks"Regards, Peter

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi