GPA 4.2: "Failed to get load library export." error message

GPA 4.2: "Failed to get load library export." error message

Hi!

I am having problems starting an application with the GPA monitor (4.2, win7 64-bit).

- I am able to profile the gpasample.exe
- I am able to profile my application on another computer.
- I am getting a "Failed to get load library export."
- I turned off the windows firewall, i dont have any anti-virus.
- EDIT: My application process does start, but stays in a dormant state, using about 112K ok memory and never really starts doing anything.

I look at the MonitorLog.txt and there is nothing relevant in there except the error message.

What do I need to do to make this work?

-Mat

6 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione
Ritratto di Neal Pierman (Intel)

Hello,

Thanks for reporting this issue. I'll check to see why this error may be occurring and get back to you with some suggestions.

Regards,

Neal

Ritratto di Neal Pierman (Intel)

Hello,

It looks like this problem has been reported internally a couple of times, and as you mentioned it only happens on some systems.

From what we've seen, this seems to occur when analyzing x86-based games/applications, and not on 64-bit apps. Please let me know whether you have a 32-bit app or 64-bit app, so that I can help narrow down whether this is the same issue as others have seen.

Fortunately, people who've seen this issue have been able to workaround the problem by using the "auto-detect" mode for attaching to your game (instead of "Analyze Application") -- can you try this and let me know what happens?

If this doesn't fix the issue, I do have some additional debugging tips that may help isolate the problem.

Regards,

Neal

Ritratto di Neal Pierman (Intel)

Hello,

Now that Intel GPA 4.3 is available, please download this latest release and let us know whether this fixes your problem.

Regards,

Neal

Ritratto di Neal Pierman (Intel)

Hello,

I just wanted to see whether trying GPA 4.3 fixed your issue, and/or whether you have more information on your specific configuration that you can provide (as requested in an earlier response).

thanks!

Neal

For guys who are trying to find a way to activate the "AUTO-DETECT" mode (From Online Help):

  1. Click the Intel GPA Monitor icon in the
    taskbar notification area and select Preferences....
  2. In the Preferences...
    dialog box select the Auto-detect
    launched applications check box and click OK.
    After this setting, whenever any D3D application starts, Intel GPA
    will attach to that process and Intel GPA System Analyzer HUD will
    be enabled. The tool automatically displays metrics as an overlay
    on the application window.

Thank you, Neal.

Accedere per lasciare un commento.