Bogus python error from Intel MPI mpdboot on Fedora Core 4

Bogus python error from Intel MPI mpdboot on Fedora Core 4

mpdboot --rsh=rsh -n 4 -f machinefile.B2210WYou can't run mpdboot on ['hoeplx2154'] version of python must be >=2.4, current ['']But rsh hoeplx2154 python -V returns Pythone 2.4.1Using Intel MPI version 2.0.Debugging show that the mpdboot command is returningrsh: invalid option -- xusage: rsh [-nd] [-l login] host [command]Why is mpdboot passing the ssh -x option to the rsh command?This same installation of Intel MPI 2.0 works fine on Fedora Core 3nodes which have python 2.3.4 installed.

3 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Dave,

I'm assuming from your message that you have configured your cluster manually. Is this correct?

Have you tried something like Rocks or OSCAR for an automatic configuration? I have used the Intel MPI version 2.0 for some time now on many Rocks configured clusters without any issues. Both packages are free and the Rocks package even includes the OS (CentOS v4.1 - repackaged RedHat EL 4 update 1)

PS. rsh is the default for the MPI invocation. Try

mpdboot -n 4 -f machinefile.B2210W

and see if you get the same result.

Dave,

It is known issue which was fixed in Intel MPI 2.0.1 release. This release is available since 04/03/2006.

Accedere per lasciare un commento.