IntelMPITEST-1.0 compiled with icc in heterogeneous environment

IntelMPITEST-1.0 compiled with icc in heterogeneous environment

Hi,

I would like to ask a question about using icc to compile
IntelMPITEST-1.0
and run the program in heterogeneous environment.

I have a i386 node and a x86_64 node.
I have configed and compiled IntelMPITEST-1.0 testsuite at the i386
node.
I run the testsuite in the i386 node, and use "mpirun -machinefile" to
run
the binary on both nodes.

I have tried the test with gcc and pgi compilers, they work.
But for icc8, I have encounter error in
c/blocking/functional/MPI_Ssend_ator

The error message is very long, but has similar pattern like:

MPITEST error (3): i=0, long double value= -0.0000000000, expected
0.0000000000
MPITEST error (3): 10 errors in buffer (3,0,13) len 8 commsize 4
commtype -10 data_type 13 root 3
MPITEST error (3): Send/Receive lengths differ -
Sender(node/length)=0/8, Receiver(node/length)=3/-32766
MPITEST error (3): i=0, long double value= -0.0000000000, expected
0.0000000000
MPITEST error (3): 117 errors in buffer (4,0,13) len 83 commsize 4
commtype -10 data_type 13 root 3
MPITEST error (3): Send/Receive lengths differ -
Sender(node/length)=0/83, Receiver(node/length)=3/-32766

All the errors are related to data_type 13 and 14.
This error does not happen when I run the tests on 2 i386 nodes.

Have you any idea on the problem? Thank you.

PS.
I find that the error message is produced from "libmpitest.c" line 2361.

And I find that one of the many compilation warning is related to the
line
./libmpitest.c(2361): warning #181: argument is incompatible with
corresponding format string conversion
i, ((derived1 *)buffer)[i].LongDouble[k],

May be it's related, I am not sure.

2 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Clotho -

I'm not familiar with the IntelMPITEST, at least, not by that name. Can you be more specific about what this application is and where you got? I know about the Intel MPI Benchmark suite, but this doesn't have the function that you mentioned by name. Also, are you running this under Windows or Linux and which MPI package are you using?

Usually, problems with the Intel compiler are best submitted to the Intel Premier Support site. Ultimately, you'll likely need to go there, but I'd like to try this out on my own if I could to see if I might be able to get some insight into the problem.

-- clay

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi