Visual Studio AppUp IDE Plug-in

Visual Studio AppUp IDE Plug-in

Hi! Right after launch i have an error message "There is no Intel AppUp(SM) Developer Program SDK found.". But i have AppUP SDK 1.0 already installed on my PC. Thanks, Dmitry
8 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Hello guys, i can't install the plugin, when i launch the .msi installer it says: "there is no Intel AppUp Developer Program SDK found" Any suggestions?

Try install the latest AppUp SDK. You can download it here http://appdeveloper.intel.com/en-us/sdk

Just found solution by myself, it requires AppUp .NET SDK to be installed (i have just SDK 1.0 for Windows C/C++).

My suggestion is to add explanation to this error message - There is no Intel .NET AppUp(SM) Developer Program SDK found. Link to download.

Update:

VS plugin does't require .NET SDK, it can be installed and works fine with C++ SDK. All you need to install plugin is just to add the registry DWORD param CppSdkInstalled = 1 to the registry node "HKEY_CURRENT_USER\Software\Intel\ADP_SDK"

I think installer and VS plugin (plugin is trys to find CppSdkInstalle param to) could be fixed, it could check SDKInstallPath param , because this param is created with the current version of the C++ SDK installer and in that case plugin will work fine with the current version of C++ SDK.

Thanks Dmitry. I'm sending this to our TME's and SDK team to see if we have a gap in our instructions or should adjust our SDK's

Dmitry we are not able to duplicate the issue you experienced. We tried a number of scenarios. When the Plug-in is installed with C++ SDK 1.0 installed it seems to work. This is a message from one of our testers on trying to install over previous versions of the SDK, or where the SDK was upgraded.

"I had tested additional scenario – install Plug-In 1.0 beta over SDK 0.92 directly.. The installation can succeed, but all the Plug-In function are disabled and notice user that C/C++ or .NET SDK is required. This is expected behavior as SDK 1.0 is required

The way I can reproduce the behavior is I have SDK 0.91 installed, then installing Plug-In 1.0 will say 'There is no Intel AppUp (SM) Developer Program SDK found'. But after I upgrade to SDK 1.0, the I’m able to install Plug-In 1.0 Beta."

I have AppUp SDK 1.0.25 installed. I was install this version on top of 0.92. As i say before i got error message during plugin installation because of missing registry key.

Now i just uninstall and re-install SDK. After installation i have check registry and key is here...

This could be my mistake or incorrect behaviour of my Windows installation, sorry.

i have downloaded the AppUpSDK_VSPLUGIN_v1.5 plugin , when i try to intall on Windows 7 32 bit machine (mine is 32 Bit)  i get a popup saying that the " The installer packaged could not open, contact the application vendor to verify that this is a valid windows installer package"

why does this error occur and what is the workaroud for this ?

 

regards

Pradish

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi