Linux Composer XE 2013 compile error: ": internal error: backend signals

Linux Composer XE 2013 compile error: ": internal error: backend signals

Ritratto di albl500

I've seen a couple of old posts that indicate that this error message is because of a compiler bug, rather than a bug in the code that is being compiled:-

": internal error: backend signals
compilation aborted for ... (code 4)

I've seen this message quite a few times since upgrading to Composer XE version 13.0.1, so thought that I'd submit a test case.. Currently trying to compile a Debug version of Inkscape from bzr:lp/inkscape. The compile command that fails, and all output:-

/opt/intel/composer_xe_2013.1.117/bin/intel64/icpc -DHAVE_CONFIG_H -D_FORTIFY_SOURCE=2 -DPOTRACE=\"potrace\" -DORBIT2=1 -DHAVE_CONFIG_H -DHAVE_CAIRO_PDF=1 -DHAVE_TR1_UNORDERED_SET -xHost -fPIC -march=corei7 -g -I/usr/local/src/inkscape/build/src -I/usr/local/src/inkscape/src -I/usr/local/src/inkscape/src/bind/javainc -I/usr/local/src/inkscape/src/bind/javainc/linux -I/usr/local/src/inkscape -I/usr/local/src/inkscape/build/include -I/usr/include/gsl -I/usr/include/gc -I/usr/include/poppler -I/usr/include/cairo -I/usr/include/gtk-2.0 -I/usr/include/gdkmm-2.4 -I/usr/include/gdk-pixbuf-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/lib/x86_64-linux-gnu/gdkmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/glibmm-2.4 -I/usr/lib/x86_64-linux-gnu/glibmm-2.4/include -I/usr/include/gtkmm-2.4 -I/usr/lib/x86_64-linux-gnu/gtkmm-2.4/include -I/usr/include/atk-1.0 -I/usr/include/atkmm-1.6 -I/usr/include/pango-1.0 -I/usr/include/pangomm-1.4 -I/usr/lib/x86_64-linux-gnu/pangomm-1.4/include -I/usr/include/cairomm-1.0 -I/usr/lib/x86_64-linux-gnu/cairomm-1.0/include -I/usr/include/giomm-2.4 -I/usr/include/sigc++-2.0 -I/usr/lib/x86_64-linux-gnu/sigc++-2.0/include -I/usr/include/freetype2 -I/usr/include/gtkspell-2.0 -I/usr/include/libxml2 -I/usr/include/ImageMagick -o CMakeFiles/inkscape_LIB.dir/extension/execution-env.cpp.o -c /usr/local/src/inkscape/src/extension/execution-env.cpp
/usr/include/glibmm-2.4/glibmm/property.h(107): warning #1098: the qualifier on this friend declaration is ignored
    friend void Glib::custom_get_property_callback(GObject* object, unsigned int property_id,
                ^

/usr/include/glibmm-2.4/glibmm/property.h(110): warning #1098: the qualifier on this friend declaration is ignored
    friend void Glib::custom_set_property_callback(GObject* object, unsigned int property_id,
                ^

": internal error: backend signals

compilation aborted for /usr/local/src/inkscape/src/extension/execution-env.cpp (code 4)

I attach the source file and preprocessed source file (the latter is large - 4.7MB; created by adding "-P" option to above command, and stripping empty lines with `sed`) which lead to this error.

The first time I came across this error was when compiling BLAST+-2.2.27. I got past errors in that by reducing the optimisation from "-O3" to "-O2", and/or removing the '-ip' flag from compile commands which failed. That's not an option with this inkscape debug build, which isn't using any compile-time optimisation flags. Removing "-xHost" and "-march=corei7" makes no difference; neither does adding any optimisation flags ("-O[23]" and / or "-ip" ).

AllegatoDimensione
Scarica execution-env.cpp6.36 KB
Scarica execution-env.cpp.o.i4.62 MB
11 post / 0 new
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione
Ritratto di Tim Prince

Include file missing, so can't compile the .cpp
Your pre-processed file seems to require a g++ of at least version 4.6 on PATH. I do see the internal error with icpc (but not g++), with g++ 4.8 on PATH.

Ritratto di albl500

I've got gcc 4.7.2, which works too. Kind of wish I hadn't uninstalled Composer XE 2011; I don't know if that would compile this successfully..

Ritratto di albl500

Strange.. If I preprocess with the "-E" option, I can then compile it, no problem, throwing any optimisation flags I like at it:-

icpc [-O3 -xHost -march=corei7 -fPIC] -c execution-env.cpp.o.i

Allegati: 

AllegatoDimensione
Scarica execution-env.cpp.o.i4.97 MB
Ritratto di albl500

Oh, I got it. The "-P" flag was working just now too :-\
Adding the "-g" flag reproduces the error..

Ritratto di Alexander Weggerle (Intel)

I was able to reproduce the error. I will give you an update as soon as I found the root cause for it.

Thanks,
Alex

Ritratto di Alexander Weggerle (Intel)

I submitted a ticket to our internal issue tracking system. The reference number is; DPD200307742.

This is not a regression. So the Composer XE 2011 shows the same error.

Thanks for submitting the issue including a reproducer! I will update the thread as soon as a fix is available.
Alex

Ritratto di albl500

Cool, thanks. I look forward to the updates!
Cheers,
Alex

Ritratto di bernaske

Hi ,

ok i have recompile the execution-env.cpp with Intel ParallelStudio XE 2013 under Linux only what i became is following:

icpc: error #10236: File not found: 'execution-env.cpp.o.i'
execution-env.cpp(11): catastrophic error: cannot open source file "config.h"
#include

and the compile process was halted

cheers
Franz

Ritratto di Alexander Weggerle (Intel)

Franz,

you also need an GCC 4.6 in path. What command did you exactly use to compile the file?

Thanks,
Alex

Ritratto di Alexander Weggerle (Intel)

Hi,

the issue is fixed in the latest version of the Compiler. Please download an update from the Intel Registrationcenter

Thanks for submitting the issue!
Alex 

Accedere per lasciare un commento.