Missing shortcut to Intel 64 for Visual Studio 2010 mode

Missing shortcut to Intel 64 for Visual Studio 2010 mode

Ritratto di Sergey Kostrov

I detected a small installation problem and please take a look at a screenshot: Thanks in advance.

AllegatoDimensione
Scarica intel64vs2010modemissing.jpg44.92 KB
4 post / 0 new
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione
Ritratto di Jennifer J. (Intel)

It seems like a bug. But do you remember the steps to get to this state? 

Jennifer

Ritratto di Sergey Kostrov

Notes:
PE - Professional Edition
EE - Express Edition

>>...It seems like a bug. But do you remember the steps to get to this state?..

Yes.

- On my primary development computer ( Windows 7 Professional 64-bit ) I have VS 2005 PE, VS 2008 PE, VS 2010 EE and VS 2012 EE
- Installed Intel Parallel Studio XE 2013 ( Initial Release ) with all options selected ( Installer worked without any problems )
- Intel C++ compiler was integrated with VS 2008 PE ( IDE )
- Intel C++ compiler is available for VS 2008 PE, VS 2010 EE and VS 2012 EE from these command line shortcuts ( or modes / see a screenshot I've provided )

In order to see these menu items you need to press 'Start' button on a 64-bit Windows OS and than follow the tree to find Intel Parallel Studio XE 2013 menu item.

Ritratto di Sergey Kostrov

>>...- Installed Intel Parallel Studio XE 2013 ( Initial Release ) with all options selected ( Installer worked without
>>any problems )

Actually, I forgot to mention one issue.

Let's say Visual Studios 2010 and 2012 Express Editions ( EEs ) were installed and SPs1 applied for both ( If SPs1 are Not applied VSs won't work ). Then, installer of Intel Parallel Studio XE 2013 does something ( possibly replaced some files ) and after that SPs1 need to be applied again. So, if I execute Windows Update after Intel Parallel Studio XE 2013 installation Windows Update shows that SPs1 are not installed for Visual Studios 2010 and 2012 EEs.

The issue is easily reproduced as follows:

- Install Visual Studio 2010 EE
- Install Visual Studio 2012 EE
- Try to launch Visual Studio 2010 EE - it won't work
- Try to launch Visual Studio 2012 EE - it won't work
- Execute Windows Update and install SPs1 for both VSs
- Try to launch Visual Studio 2010 EE - it will work
- Try to launch Visual Studio 2012 EE - it will work
- Install Intel Parallel Studio XE 2013 ( Initial Release )
- Try to launch Visual Studio 2010 EE - it won't work
- Try to launch Visual Studio 2012 EE - it won't work
- Execute Windows Update ( it shows that SPs1 are not installed for both VSs ) and install SPs1 again
- Try to launch Visual Studio 2010 EE - it will work
- Try to launch Visual Studio 2012 EE - it will work

Note: I know that in case of Express Editions Intel Parallel Studio XE 2013 doesn't do integration with IDEs. However, something is wrong and please try to investigate.

Accedere per lasciare un commento.