Using RUNQQ

Using RUNQQ

I'm trying to utilize the RUNQQ procedure on a 64 bit Intel machine.

My code compiles fine but RUNQQ will return an error code of 2 using GETLASTERRORQQ; which appears to be related to ERR$NOENT (as found in IFPORT.F90 code)

The result from RUNQQ itself is -1

What my be causing this?  I've tried doing several things using RUNQQ with no success.

I've been able to get SYSTEM and SYSTEMQQ to work OK on my machine but not RUNQQ

Thanks for advice.

 

4 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

I would guess it is the path the the program you are trying to run. Give the program nane including the full path in 'quotes'  perhaps?

By placing the procedure I want to call using RUNQQ into the same directory as my procedure containing the RUNQQ call, it works.

I had assumed that as long as the procedure being called by RUNQQ was in my defined PATH it would be accessed but apparently not......

And including the entire path in the RUNQQ call would accomplish this also.

Thanks

  

In windows the 'local' path is what windows decides....  I normally call get_command_argument to get the loacation of the exe that is running and then append the program to run on the end of this path...

iarg=0 !get cmd line for locn of .exe, used for file locns
 call get_command_argument (iarg, garg, ilen, istat)
 if(istat.eq.0) then
 ncdpth=index(garg,'',.true.)
 gcdpth=garg(1:ncdpth)
 else
 ncdpth=0
 endif

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi