Disable 'Enable User Notification' option in IMSS

Disable 'Enable User Notification' option in IMSS

Hi

I'd like to disable the 'Enable User Notification' option in IMSS for all versions of this software but it appears to require different registry keys depending on version. (e.g. Version 8.1 uses "ShowUserNotification") Does anyone have a comprehensive list of which registry key changes this for all versions or would disabling the 'Intel Management and Security Application User Notification Service' be a better option?  I'm reluctant to do this as I don't know if this will prevent the functionality of the software in any way.

Thanks,

Jim

9 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Isn't there a check box if you bring up the IMSS tool to disable UNS?  Otherwise you could stop the service.

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Thanks for the reply Gael.  Yes, there is a checkbox but I want to do this for thousands of machines, so if I knew how to control that checkbox via the registry, I could script this.  I'm just a litle concerned that disabling the service might be overkill.

Ah.  I see.

For what versions of AMT are you wanting to disable the UNS?  (stopping the service might be the quickest way to do this programatically.)

I have been looking at the registry for AMT 7 and 8 and the advice in the blog below won't work.  I will continue to investigate and get back with you when I find out more information.

The  blog addresses your question for older versions of AMT - there is no atchk.exe on newer systems, for example

http://software.intel.com/en-us/blogs/2008/10/12/more-configurations-dis...

On my AMT 7 system is see that the executable has changed and appears to be here:

C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\UNS

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Amt 7.0 uses the "ShowUserNotification" registry key as well:

Computer\HKEY_CURRENT_USER\Software\Intel\PIcon\Setting\ShowUserNotification

What other versions of AMT are you working with? 

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

We are using version 9.5, and that registry key doesn't seem to apply. is there any further advice?

Thierry, I apologize for the delay.  We are looking into this.

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Here is an update:

First, LMS and UNS are now one service (so i you disable UNS, you will be disabling LMS - not sure you want to do that.)

You can run a batch file with the following:

  • sc config LMS start=disabled

You can also do this programatically  (c/c++) using the following API:

In the registry:

I hope this helps.

 

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Doesn't seem as I would like to disable this all. The only thing that should be disabled is the end user notifications. eg. the user always gets: intel anti theft is disabled (which is by design as intel deprecated the feature and we already phased it out). the notification popup appears on the desktop top right corner.

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi