Haswell system: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*)

Haswell system: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*)

Ritratto di jmbnyc@gmail.com

I tried to update my vtune install to the latest (update 11) and now only basic hopspot analysis is available. Any of the other advanced analysis activities are avaibale. All of the drivers have been built properly (with the -pu flag) and installed but the analsys screens in ample-gui suggest that there is an issue with the driver.

#uname -a 

Linux haswell 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug 29 18:46:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

# insmod-sep3 -q

pax driver is loaded and owned by group "vtune" with file permissions "660".
sep3_10 driver is loaded and owned by group "vtune" with file permissions "660".
vtsspp driver is loaded and owned by group "vtune" with file permissions "660".

not sure what else to try or do?

13 post / 0 new
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione
Ritratto di Peter Wang (Intel)

I don't think the problem is Haswell specific issue, but you can refer to this thread - http://software.intel.com/en-us/forums/topic/372533

Hope it helps.

Ritratto di jmbnyc@gmail.com

Peter,

Thanks for the reply but I don't believe the post you cited is the same issue. I have everything set up properly but it still does not work. I recently upgraded my system from ivybridge (it worked fine) to haswell and now it does not work properly. 

Ritratto di MrAnderson (Intel)

Hi:

Try uninstalling and reinstalling the drivers:

  1. as root, cd to /opt/intel/vtune_amplifier_xe/sepdk/src
  2. ./rmmod-sep3 -s
  3. ./insmod-sep3 -pu [...]
  4. then, as a user, source amplxe-vars.sh (usually in /opt/intel/vtune_amplifier_xe)
  5. and try: amplxe-cl -c advanced-hotspots -duration 5 -r /tmp/test@@@

You can use -h for help to see options for the sep3 scripts (I may or may not have remembered them exactly).  Step 5 should collection five seconds of sampling data.  If it doesn't, please tell us what the message is from the amplxe-cl command.

Regards, MrAnderson
Ritratto di jmbnyc@gmail.com

MrAnderson,

Thanks. I already tried that a few times but tried it again as you suggested. Here is the output.

[jmb@haswell bin64]$ ./amplxe-cl -c advanced-hotspots -duration 5 -r /tmp/te@@@
amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.

i have a "vtune" and user jmb is in the user group.

/JMB

Ritratto di MrAnderson (Intel)

Thanks, JMB.

One question: did you add your user to the vtune group and, without logging out and back in, try to access the driver?  If you didn't log out, the group changes don't actually get activated.  Make sure you have logged out and back in as the user attempting to collect data.

Next, do an ls -l /dev/sep*.  What is the output?  Is group ownership vtune?  Does the group have read and write access to the device files?

If everything looks like it should work, try unloading the drivers (./rmmod-sep3 -s) and reloading them granting permissions to all users (./insmod-sep3 -pu -p 666) and see if that makes a difference.

Regards, MrAnderson
Ritratto di jmbnyc@gmail.com

this might be interesting.

[root@haswell src]# ./insmod-sep3 -pu
Checking for PMU arbitration service (PAX) ... not detected.
Attempting to start PAX service ...
Executing: insmod ./pax/pax-x32_64-3.5.3-1.fc17.x86_64smp.ko
Creating /dev/pax device with major number 246 ... done.
Setting group ownership of devices to group "vtune" ... done.
Setting file permissions on devices to "660" ... done.
The pax driver has been successfully loaded.
PAX service has been started.
PAX service is accessible to users in group "vtune".
Executing: insmod ./sep3_10-pu-x32_64-3.5.3-1.fc17.x86_64smp.ko
Creating /dev/sep3_10 base devices with major number 245 ... done.
Creating /dev/sep3_10 percpu devices with major number 244 ... done.
Setting group ownership of devices to group "vtune" ... done.
Setting file permissions on devices to "660" ... done.
The sep3_10 driver has been successfully loaded.
Checking for vtsspp driver ... not detected.
Executing: insmod ./vtsspp/vtsspp-x32_64-3.5.3-1.fc17.x86_64smp.ko gid=1004 mode=0660
The vtsspp driver has been successfully loaded.
[root@haswell src]# ls -l /dev/sep*.
ls: cannot access /dev/sep*.: No such file or directory

The vtune group has been around for quite a long time (years) and user "jmb" has been in that group for a long time so that can't be the issue.

[root@haswell src]# lsmod | grep sep
sep3_10 110317 0
[root@haswell src]# lsmod | grep pax
pax 12992 0

Ritratto di MrAnderson (Intel)

Hmmm, what do you see in /dev?  What are the permissions on /dev?

Regards, MrAnderson
Ritratto di jmbnyc@gmail.com

in /dev

drwxrwxr-x   2 root vtune          240 Jul 22 16:55 sep3_10

[root@ivybridge amps]# ls -latr /dev/sep3_10/
total 0
crw-rw---- 1 root vtune 245, 1 Jul 22 16:55 m
crw-rw---- 1 root vtune 245, 0 Jul 22 16:55 c
drwxr-xr-x 22 root root 3720 Jul 22 16:55 ..
crw-rw---- 1 root vtune 244, 0 Jul 22 16:55 s0
crw-rw---- 1 root vtune 244, 1 Jul 22 16:55 s1
crw-rw---- 1 root vtune 244, 2 Jul 22 16:55 s2
crw-rw---- 1 root vtune 244, 3 Jul 22 16:55 s3
crw-rw---- 1 root vtune 244, 4 Jul 22 16:55 s4
crw-rw---- 1 root vtune 244, 5 Jul 22 16:55 s5
crw-rw---- 1 root vtune 244, 6 Jul 22 16:55 s6
crw-rw---- 1 root vtune 244, 7 Jul 22 16:55 s7
drwxrwxr-x 2 root vtune 240 Jul 22 16:55 .

Ritratto di MrAnderson (Intel)

you seemed to have switched systems on me?  That output is for "root@ivybridge", but previously you were "root@haswell".  What does /dev look like on the "haswell" system?

And, did you try "-p 666"?

Regards, MrAnderson
Ritratto di jmbnyc@gmail.com

they are the same system. the name of the box is "ivybridge" but it should be "haswell". i name all of boxes for the chip. this box was built with ivybridge but then I swapped MB (and chip) to haswell but am still using the same SSD. I was chaning the name in the output so that I would not create confusion. the box is haswell.

model name : Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz

sorry for the confusion.

/JMB

Ritratto di MrAnderson (Intel)

okay, thanks.  I don't understand, then, why you first reported:

[root@haswell src]# ls -l /dev/sep*.
ls: cannot access /dev/sep*.: No such file or directory

and then:

[root@ivybridge amps]# ls -latr /dev/sep3_10/
total 0
crw-rw---- 1 root vtune 245, 1 Jul 22 16:55 m
crw-rw---- 1 root vtune 245, 0 Jul 22 16:55 c
drwxr-xr-x 22 root root 3720 Jul 22 16:55 ..
crw-rw---- 1 root vtune 244, 0 Jul 22 16:55 s0
.
.

???   Anyway, try "-p 666" and see if it makes any difference.

Regards, MrAnderson
Ritratto di jmbnyc@gmail.com

well, the first time I did it that is what  the ls returned. when I ran it again I saw sep3_10. not sure what happened (this is why I said it might be interesting).

however I just looked back I see that it was a grep issue.

ls -l /dev/sep*. vs ls -l /dev/sep*

Accedere per lasciare un commento.