Error: Cannot check availability of per-thread posix timer.

Error: Cannot check availability of per-thread posix timer.

Hello,

Intel VTune does not work for me anymore. When I call

.../vtune_amplifier_xe_2013/bin64/amplxe-cl -collect hotspots -app-working-dir MyWorkingDir -- MyApp

I get the error message

Cannot check availability of per-thread posix timer.amplxe: Error: Cannot check availability of per-thread posix timer.

and the result is empty. I get the same error message when using the GUI. The application is compiled using icpc. Any ideas?

 

Kind regards

Benjamin

 

Software Versions:

icpc (ICC) 13.1.3 20130607

Intel(R) VTune(TM) Amplifier XE 2013 Update 11 (build 300544)

14 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Hi Benjamin:

I'm checking on this.  I don't recall seeing this message before. Can you tell me what OS you are using?

Also, have you tried sourcing the amplxe-vars.sh file and using just amplxe-cl instead of the full path?  Sourcing sets up a few things so that amplxe-cl and -gui can find everything they need.

Regards,
MrAnderson

Citazione:

MrAnderson (Intel) ha scritto:

I'm checking on this.  I don't recall seeing this message before. Can you tell me what OS you are using?

I am using Debian GNU/Linux jessie/sid.

Citazione:

MrAnderson (Intel) ha scritto:

Also, have you tried sourcing the amplxe-vars.sh file and using just amplxe-cl instead of the full path?  Sourcing sets up a few things so that amplxe-cl and -gui can find everything they need.

I tried sourcing and calling amplxe-cl directly, but it makes no difference. I get the same error message.

I had one customer to report similar error message:

Error: can't check availability of per thread posix timer

The reason was that custom $string in /proc/version? /proc/sys/kernel/ostype? /proc/sys/kernel/osrelease?. It prevents us from detecting correct kernel version. If you removed these custom string - it will work.

I guess that you use early Amplifier XE 2013 version to meet this limitation, please try U11 and let me know if it works (I mean without moving custom string). Thank you.

Citazione:

Peter Wang (Intel) ha scritto:

The reason was that custom $string in /proc/version? /proc/sys/kernel/ostype? /proc/sys/kernel/osrelease?. It prevents us from detecting correct kernel version. If you removed these custom string - it will work.

Here are my strings:

/proc/version
Linux version 3.10-2-amd64 (debian-kernel@lists.debian.org) (gcc version 4.7.3 (Debian 4.7.3-6) ) #1 SMP Debian 3.10.5-1 (2013-08-07)

/proc/sys/kernel/ostype
Linux

/proc/sys/kernel/osrelease
3.10-2-amd64

Citazione:

Peter Wang (Intel) ha scritto:

I guess that you use early Amplifier XE 2013 version to meet this limitation, please try U11 and let me know if it works (I mean without moving custom string). Thank you.

As I wrote in my first post, I am using U11 already.

Probably Linux kernel version 3.10 is too high and U11 hasn't been tested on that platform.

I wonder that recent supported Debian* 7.0 Linux has Linux kernel 3.2 version.

This sounds to me that I cannot do anything to fix the problem except waiting for the next VTune version.

Another way is to downgrade Linux kernel version in your box, sorry to say this!

The problem persists with Update 12 of Intel VTune Amplifier XE 2013.

Current U12 supports new OS Fedora* 19 - Linux kernel version is 3.9 :-(

I downloaded the trial version of Vtune. I have the same problem on Debian "testing".

$ amplxe-cl --version
Intel(R) VTune(TM) Amplifier XE 2013 Update 15 (build 328102) Command Line Tool
Copyright (C) 2009-2013 Intel Corporation. All rights reserved.

$ cat /proc/version
Linux version 3.12-1-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.2 (Debian 4.8.2-10) ) #1 SMP Debian 3.12.6-2 (2013-12-29)

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 45
model name      : Intel(R) Xeon(R) CPU E5-1620 0 @ 3.60GHz

...

 

I remember that this problem was fixed long time ago. Anyway, I reported this to our engineering. I will post any update, soon

I have the same issue, on Debian testing (Linux version 3.12-1-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.2 (Debian 4.8.2-10) ) #1 SMP Debian 3.12.6-2 (2013-12-29)).

amplxe: Error: Cannot check availability of per-thread posix timer.
amplxe: Collection detached.

I can run the basic "-collect advanced-hotspots" mode, but "-collect hotspots" gives the error above, and the two "-knob collection-detail" options supported both cause my entire machine to lock up.

The drivers are running:

$ ./insmod-sep3 -q
pax driver is loaded and owned by group "vtune" with file permissions "666".
sep3_10 driver is loaded and owned by group "vtune" with file permissions "666".
vtsspp driver is loaded and owned by group "vtune" with file permissions "666".

Thank you, for the report.

This issue is for user-mode sampling collections, they are hotspots, concurrency, locksandwaits analysis. So they are not vtune drivers relevant.

In order to gather more clues to help engineering on investigating, I needs your helps:

1. Are you sure that you work on latest VTune Amplifier XE 2013 Update 15? (Debian* 7 already is supported)

2. Is it possible that you do, 

Before running amplxe-cl - do "export TPSS_COLLECTOR_DEBUG=1", this will help to generate log files in result directory. Please zip result directory then attach your result.

After data collection - run "amplxe-feedback -create-bug-report <report archive>", attach log.zip it may help to understand your environment. 

Thank you again.

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi