Malfunctioning of the MPI library with Ifort Compiler for Windows

Malfunctioning of the MPI library with Ifort Compiler for Windows

Hi,

First of all, I'm sorry because I'm posting my topic on this forum. I'm not allowed to do it on the Parallel Studio Forum. I hope you could help me here.

I started recently programming with the Intel MPI library associated to the Intel Visual Fortran composer for Windows. Even if my test code recognize the MPI library, many of the MPI simple subroutines didn't work, even well set ! For example, this simple code didn't create the file 'data.txt' :

program main

        use mpi

        implicit none

        integer :: descripteur,code
        
        call MPI_INIT(code)
        
        call MPI_FILE_OPEN(MPI_COMM_WORLD,"data.txt",MPI_MODE_RDWR+MPI_MODE_CREATE,MPI_INFO_NULL,descripteur,code)
        
        call MPI_FILE_CLOSE (descripteur,code)
        call MPI_FINALIZE (code)
         
end 

Can someone please help me ! why such a simple code do not work ?

Thanks a lot.

3 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Those obsolete forum sections ought to be moved out of the way to a separate category, in my opinion.

That particular forum never supported Fortran nor MPI, so  you would have wasted your time with it.

Intel MPI support is primarily on the Clusters and HPC companion forum.

I'm trying out your case under Windows 8.1 "intel64."  It may be of interest to know your platform.

I see, with /traceback set in compile, it crashes on MPI_FILE_CLOSE.

I'm concerned about declaring a file handler as a default integer.  I believe ifort has Microsoft style names for such data types.

I'm certainly running afoul of the gratuitous obstacles placed in the way under Win8.1.

Did you find the Windows MPI documentation?

http://software.intel.com/sites/products/documentation/hpc/mpi/windows/r...

 

Thanks for you answer TimP. I posted also my question on the Clusters and HPC forum. Unfortunately, I didn't get any answer. I really don't understand why did it not work !!!! the MPI_FILE_OPEN don't create the file and return a bizarre ierror value 536929056 !! 

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi