problem with depth stream

problem with depth stream

Hi all,
I'm new to intel perceptual computing and quite new to c++ (used at least 10 years ago)

I'm experimenting a strange behaviour with the depth stream, when running the examples provided with the sdk. Basically, the depth streams looks "striped" (attached you can find and image) with any of the example apps. This depth stream is useless.
However I was able to got a normal depth stream when running two app at the same time. o_0 
Here are the cases:
a) Run the GestureViewer sample alone => I got a "striped" depth stream
b) Run the CameraViewer sample alone => I got a "striped" depth stream
c) there are two steps:
    1 - Run the GestureViewer sample  => I got a "striped" depth stream
    2 - Run the CameraViewer sample while GestureViewer is still running => The depth stream of GestureViewer is fixed and the CameraViwer has a normal depth stream (when windows doesn't show the blue screen of death). 
    
The same behaviour happens if I run the app I wrote following the sdk tutorials "My First C++ Application" in spite of the GestureViewer (except that I never got windows blue screen of death in this case).

I thought it would depend on how an app start the camera and its depth streams but I wasn't able to solve it so far. Moreover it looks strange to me because, at least, sdk's apps should work. Have I made something wrong? Have you any ideas? 
(My so is windows7, I'm using visual studio 2012 and the camera is the creative senz3d.)

Thanks in advance to anyone :D

AllegatoDimensione
Download striped_depth_stream.png33.88 KB
9 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Mike, what the firmware version of your Creative camera? Could you try this firmware update tool and let me know if it fixes the problem for you?
http://ccfiles.creative.com/ManualDn/Applications/VNI/13074/0x67723BF7/C...

 

Hi David! first of all thank you for your quick reply!

Concerning the firmware version, I'm attaching the skd_info file, I saw on an other post that you can verify it from that file (btw, when running the firmware update it says: 'current version: 21.07')

I have also tried to run the 'firmware update tool' but it says: "The current firmware in your device has the same version. Do you want to continue?". So it seems that the firmware is already up-to-date, however i continued the upgrade process and completed it successfully. Unfortunately nothing changed when I tried the sample apps. After that I have also reinstalled the sdk from the internet and everything started working as before.

Allegati: 

AllegatoDimensione
Download sdk_info_before_update.TXT8.37 KB

 

An update..I have tested the camera and the intel sdk (installed from internet) with the windows 8 64 bit (version: 6.2.9200) os. On that computer the provided samples are working correctly (except for one which blocks after start up, however the depth stream for other samples is ok!). Does the problem concern the camera/firmware with windows 7?

Thanks,

Mike

Thanks for the update. We are investigating this issue and will keep you post. 

 

Thank you very much!!

I'll wait for updates and I'll write if i achieve something. 

As a temporary workaround, using a previous version of the sdk would help? Are they available somewhere? thanks again :)

Mike, you can try the previous PerC SDK version and see if there is any different. You can download the PerC SDK R6 version from http://registrationcenter-download.intel.com/akdlm/irc_nas/3581/intel_pc... 

Thank you! Unfortunately nothing changed, the examples behave like they do with the R7 version, however it was worth a try :)

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi