Some projects can't compile when using C++ Composer XE 2015 beta

Some projects can't compile when using C++ Composer XE 2015 beta

Hello,

Tried the newest Intel C++ Composer XE 2015 Pre-Release beta. (2015.0.0.30)

I can successfully compile most projects without issue.

but I got an error on some projects:

3>xilink: : error #10037: could not find 'llvm_com'
3>xilink: : error #10014: problem during multi-file optimization compilation (code -1)
3>xilink: : error #10014: problem during multi-file optimization compilation (code -1)

Did I miss something?

My IDE is VS2013

Thanks

5 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

Have no issue when using C++ Composer XE 2013 SP1 update2

sorry for the double post

Have you submitted a bug report at Intel® Premier Support?  That's the typical way to report problems with beta releases of the Intel compiler suites.  If you're part of the beta program, you have access to Premier Support.

I encountered a setup/initialization problem which is not unique to the beta compiler.  A clean set of default environment variables under Advanced System Settings is needed such that vcvarsall.bat in Visual Studio works correctly with whichever architecture setting you require.  It was possible to set up so that ICL for Intel64 was missing bits from Microsoft CL 64-bit (because vcvarsall was dropping to 32-bit selection when it didn't correctly resolve paths from \windows\system32\).

Not as many Intel software tools as in the past are leaving behind environment variable settings which can interfere with new installations.

The problem is not necessarily caught during installations; it may work fairly well at first then fail after reboot.

Lascia un commento

Eseguire l'accesso per aggiungere un commento. Non siete membri? Iscriviti oggi