Vtune with kvm

Vtune with kvm

Hi

I am novice to Vtune and trying to learn as much as I can but I am stuck with few warnings..I hope I can get through with your help.

I have been trying to use the vtune for kernel level analysis in virtualized environment with kvm and qemu. Host os : fedora 20, 3.15.6 Guest os : fedora 18, 3.11

I have installed the following packages on the host

kernel-debuginfo-3.15.6-200.fc20.x86_64

kernel-debuginfo-common-x86_64-3.15.6-200.fc20.x86_64

 I am not able to drill down the kvm_intel functions and the warning shows that could not find the file kvm_intel.ko.

Could you please suggest me if I have to enable any flags for kvm or the path directories for the modules and debugging symbols.

binary/symbol paths: /usr/src/debug/kernel-3.15.fc20/`uname -r`; /usr/src/kernels/linux-3.15.6/  ( vmlinux) ; /usr/lib/debug/lib/modules/`uname -r`

source : /usr/src/kernel/kernel-3.15.fc20/`uname -r`;   /usr/sbin;  /usr/lib/modules/`uname -r`/source.

Please find the attachment of the warning log.

 

Thank you,

Monica.

AllegatoDimensione
Download 0 byte
5 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

I am sorry for the inconvenience .The log did not attach successfully. Please consider this.\

Data collection is completed successfully
    Tue 29 Jul 2014 02:17:47 PM MST  The result file '/root/intel/amplxe/projects/ovs/r002ah/r002ah.amplxe' is successfully created and added to the project ovs.
Finalization completed with warnings
    Tue 29 Jul 2014 02:49:14 PM MST  Result finalization has completed with warnings that may affect the representation of the analysis data. Please see details below.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libamplxe_cpil_2.16.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libmutter.so.0.0.0'.
    Cannot locate debugging symbols for file `/usr/lib64/libpixman-1.so.0.30.0'.
    Cannot locate debugging symbols for file `/usr/lib64/libatspi.so.0.0.1'.
    Cannot locate debugging symbols for file `/usr/lib64/xorg/modules/input/evdev_drv.so'.
    Cannot locate debugging symbols for file `/usr/local/bin/qemu-system-x86_64'.
    Cannot locate debugging symbols for file `/usr/lib64/libc-2.18.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libgobject-2.0.so.0.3800.2'.
    Cannot locate debugging symbols for file `/usr/lib64/libgdk-x11-2.0.so.0.2400.22'.
    Cannot locate debugging symbols for file `/usr/lib64/libgtk-x11-2.0.so.0.2400.22'.
    Cannot locate debugging symbols for file `/usr/lib64/libxcb.so.1.1.0'.
    Cannot locate debugging symbols for file `/usr/lib64/libpango-1.0.so.0.3600.1'.
    Cannot locate debugging symbols for file `/usr/lib64/gnome-shell/libgnome-shell.so'.
    Cannot locate debugging symbols for file `/usr/bin/Xorg'.
    Cannot locate debugging symbols for file `/usr/lib64/libclutter-1.0.so.0.1600.2'.
    Cannot locate debugging symbols for file `/usr/lib64/xorg/modules/libshadow.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libpangocairo-1.0.so.0.3600.1'.
    Cannot locate debugging symbols for file `/usr/lib64/libglib-2.0.so.0.3800.2'.
    Cannot locate debugging symbols for file `/usr/lib64/xorg/modules/libfb.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libgdk_pixbuf-2.0.so.0.3000.3'.
    Cannot locate debugging symbols for file `/usr/lib64/libcogl.so.15.3.0'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libamplxe_gen_helpers_core_2.19.so'.
    Cannot locate debugging symbols for file `/usr/sbin/ovs-vswitchd'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libamplxe_libxml_2.7.so'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libamplxe_gen_helpers_das_2.19.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libpthread-2.18.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libXrender.so.1.3.0'.
    Cannot locate debugging symbols for file `/usr/lib64/dri/swrast_dri.so'.
    Cannot locate debugging symbols for file `/usr/lib64/xorg/modules/drivers/modesetting_drv.so'.
    Cannot locate debugging symbols for file `/usr/lib64/ld-2.18.so'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libwx_gtk2-2.8.so.0.8.0'.
    Cannot locate file `kvm_intel.ko'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/bin64/amplxe-gui'.
    Cannot locate debugging symbols for file `/usr/lib64/libX11.so.6.3.0'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libstdc++.so.6.0.12'.
    Cannot locate debugging symbols for file `/opt/intel/vtune_amplifier_xe_2015.0.1.358460/lib64/libamplxe_wx_helpers_core_1.19.so'.
    Cannot locate debugging symbols for file `/usr/lib64/libharfbuzz.so.0.927.0'.
    Cannot locate debugging symbols for file `/usr/lib64/libcairo.so.2.11301.0'.
    Cannot locate debugging symbols for file `/usr/lib64/libm-2.18.so'.
    Cannot locate debugging symbols for file `/usr/lib64/firefox/libxul.so'.
Thank you.

Please see answer from this thread

Hi Peter,

Thanks for your prompt reply.But i am still unclear with this.

It does not state that Hardware Event-based Sampling is not supported on this operating system. I could do the advanced hotspot analysis but with some warnings like cannot find the kvm_intel.ko file . I have given the direct path in the search directories.

Please help me.

Thank you,

Moica.

>  I am not able to drill down the kvm_intel functions and the warning shows that could not find the file kvm_intel.ko.

I'm not sure if kvm_intel.ko is an existing module, you worked on KVM. Using PMU hardware event-based sampling (e.g. advanced-hotspots) is not encouraged), please "hotspots" instead, or you work on Linux operation system installed in none virtual machine environment.

 

Accedere per lasciare un commento.