Call Count column does not appear

Call Count column does not appear

Hi.  I'm running Advanced Hotspots analysis with Hot Spots, call counts, stacks and context switches checked  However, when I look at the results, I don't see Call Count column.  I have Show All columns checked and scrolling to the right or left does not reveal a column.  Any idea?  Thanks.

AllegatoDimensione
Download Columns.PNG58.73 KB
Download AnalysisType.PNG22.99 KB
17 post / 0 nuovi
Ultimo contenuto
Per informazioni complete sulle ottimizzazioni del compilatore, consultare l'Avviso sull'ottimizzazione

If you already did "Show All Columns", it might be due to vtss plus driver was not enabled.

Do you work on Linux*? I remember that the feature needs Linux kernel version 2.6.32 or above.

Check - "lsmod | grep vtsspp" if that driver was loaded.

Another thing is - are your sure if your hot function calls were low number, this might cause "call count" column invisible. You may build a simple example which calls hot functions frequently from a loop, then verify.

This is VMware 10, Windows 7 environment.  Thanks.

Try to run from elevated cmd driverquery -v and look for vtss.sys driver entry. Pay attention to started and running info.

@ L K

Thanks for info. However I wonder that only operation system on VMWare Fusion* 5 is supported to run hardware event-based sampling - as I know you ran advanced-hotspots, but I saw your all CPI values are zero!!! Can you verify this issue in native operation system?

Thanks, Peter   

@L K

What is your host OS?

Host OS - Windows 7, 64 bit

Guest, VMWare 10, Windows 7, 32 bit

vtss is running

Thank you.

Did you try to check functions call count while profiling your code on the Host machine?

In order to verify if this is problematical result (I saw that CPI is zero in columns.png), you can use command line to display interest of data from  the report by using:

amplxe-cl -report hotspots; // which should display "call count" column, if you enabled it during data collecting.

amplxe-cl -report summary; // verify CPI value in this report, it it zero? It doesn't make sense.

@Peter

Is there a possibility to receive or redirect VTune output to comsole window only without loading UI? I was thinking about the possibility of failure related to some column CPI UI handler.

>>>Is there a possibility to receive or redirect VTune output to comsole window only without loading UI>>>

Of course as a diagnostic option.

I ran command option followed by > summary.txt and got the output ( or most of it? ) to the file. See attached.  Does VTune support advanced hotspots on VMware Workstation ( Win 7 guest & Host )?  It would take me a bit to set it up on non-VM environment to see if I get correct results ( even if I do - my expectation was that I could run this on VM as I used to with an old version of VTune - I'm aware of changes ).  I can try running sample and analyzing it on the same VM & see what I get...

here are hotspot columns ( 3 ):

Function                                                                                          Module                  CPU Time:Self
------------------------------------------------------------------------------------------------  ----------------------  -------------
KiFastSystemCallRet                                                                               ntdll.dll                       4.152
func@0x1006b351                                                                                   MSO.DLL                         0.984
func@0x10008f53                                                                                   OLMAPI32.DLL                    0.980
func@0x101608d1                                                                                   MSO.DLL                         0.802
func@0x1015b0bc                                                                                   MSO.DLL                         0.241
func@0x100048c0                                                                                   MSPST32.DLL                     0.204
CUserThread::SendRequest                                                                    mydll.dll                     0.186
 

Summary is attached.

 

Allegati: 

AllegatoDimensione
Download summary_0.txt3.18 KB

Looks like most of the CPU time is spent in kernel-to-user mode stub function.  Does your code frequently call into kernel mode?

 

The application being profiled is Microsoft Outlook so that's expected.  It's not the point, however.  We are trying to figure out where did the Call counts go...Peter was looking for a meaningful  value for CPI as well.

They are unexpected results.

Event summary
-------------
Hardware Event Type               Hardware Event Count:Self  Hardware Event Sample Count:Self  Events Per Sample
--------------------------------  -------------------------  --------------------------------  -----------------
INST_RETIRED.ANY                                          0                                 0  2700000          
CPU_CLK_UNHALTED.THREAD                                   0                                 0  2700000          
CPU_CLK_UNHALTED.REF_TSC                        46382069573                             23191  2000003         

No sample are collected for INST_RETIRED.ANY and CPU_CLK_UNHALTED.THREAD, so there is no CPI value.

And, no "call count" column in hotspots report.

> Does VTune support advanced hotspots on VMware Workstation ( Win 7 guest & Host )?  

No. You have to work on native operation system. 

You can run basic-hotspots, concurrency, and locksandwaits on VMware workstation with Win 7, because they are user-mode sampling and no PMU resource access. 

Already then.  Once I get a chance I'll try without virtualization.

Citazione:

L K. ha scritto:

The application being profiled is Microsoft Outlook so that's expected.  It's not the point, however.  We are trying to figure out where did the Call counts go...Peter was looking for a meaningful  value for CPI as well.

I was under assumption that it was your application.

Accedere per lasciare un commento.