Debugging

The Intel® Parallel Studio XE 2016 Beta program is now available!

In this beta test, you will have early access to Intel® Parallel Studio XE 2016 products and the opportunity to provide feedback to help make our products better.  Registration is easy through the pre-Beta survey site.

 

This suite of products brings together exciting new technologies along with improvements to Intel’s existing software development tools:

 

Intel(r) Parallel Studio XE 2015 Professional Edition

The latest release of Intel(r) Parallel Studio is now available.

If you have an active support license for Intel Parallel Studio, the Intel® Parallel Studio XE 2015 products are now available for download from the Intel® Registration Center.

New features for Intel® Inspector XE 2015:

spring3+hibernate4 service 中多线程事务异常及解决

初次使用spring3结合hibernate4做项目,迅速配置完成,测试,一切正常。

然而,当我在service层中另外开启一个线程,线程中的方法需要进行数据库操作,这个时候,悲催的抛出了异常:-org.hibernate.HibernateException: No Session found for current thread

当然,hibernate4的session是和当前线程绑定的,多线程中用sessionFactory.getCurrentSession()获取当前session自然不存在,不存在又不会自动创建,所以抛出了异常,无可厚非。

于是就想着怎么解决这个问题。

遍翻google、baidu,大部分都说如何如何配置,设置事务的传播属性propagation="REQUIRED",开启opensessioninview filter等等,无一对此问题有何解释(当然或许是我没翻到,有知道的麻烦告知)

在http://sishuok.com/forum/blogPost/list/2625.html#7523上看到相关配置,我就想作者这个项目该多线程运行正常吧,果断下载源码,修改测试,oh。。。跟我的错一模一样!

Welcome to the Debug Solutions User Forum

This user support forum is the place to ask questions and consult with fellow developers on topics related to all of Intel's debug solutions. Please feel free to submit questions and start discussions at

Debug Solutions User Forum

http://software.intel.com/en-us/forums/debug-solutions/

The topics may range from GDB*, Intel JTAG Debugger, Intel Debugger, Intel Parallel Debugger Extension, and Intel Fortran Expression Evaluation to Debug Methodologies, and Tips and Tricks.

Cannot find bandwidth value in VTune

Hello,

My CPU is Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz.

I choose the Microarchitecture Analysis/Bandwidth and start the testing.

In the Bandwidth viewpoint panel, where is the average Bandwidth?

I put my screen shot in the attachment. I cannot find the bandwidth.

 

I also use the command line and the result is as follows. The bandwidth is zero. How come?

 

Summary
-------
Elapsed Time:       70.813 
CPU Time:           644.534
Average CPU Usage:  8.906  
CPI Rate:           1.107  

Command line reports matching gui

Hi Intel experts,

I'm currently running a custom advanced hotspots analysis using the amplxe-cl -collect command. The analysis is created by copying Advanced Hotspots analysis and scrolling to the bottom to check the box "Analyze the energy taken by processor cores..."

I run the command: 

amplxe-cl -collect advanced-hotspots-0 -r report -- ./run.sh

What is Intel® INDE? Why Should I Care?

Imagine yourself in a brain storming session with your colleagues.  You have an idea for the next hit mobile application.  You know what features you want to implement. You know your target user.  At this point your requirements are starting to become defined.

But there is a problem: what platform? What architecture? What operating system?  As a developer, you want your brilliant application to be enjoyed by all.  In a market where there are countless platforms and many prominent OS choices, it’s difficult to choose how to approach the problem.  

Intel VTune for Embedded Windows OS

Hi all,

I am wondering if it is possible to use VTune 2013 or VTune2015 using Windows embedded and, if yes, what is the minimum supported windows edition. I read on the release notes that "embedded editions not supported" but I would like to know if there is a way for example to collect data on an embedded system and view results on standard windows system and/or to perform remote mode using Windows embedded target.

Thanks,

Giorgio

vtune 2013 and very long run hotspot analysis

A customer using vtune 2013 tried this command line for a 40+ hour long run, 16 MPI ranks - I know, it's asking a lot.  Customer reported:

"We've been trying to use it for a problem that runs for 40+ hours/

The elapsed time reported in vtune is far less than it should be, something like 1 hour in this case. Also, the finer-grain times reported when browsing the functions appear to be far smaller than expected.

Iscriversi a Debugging