Android* Applications on Intel® Architecture

Android emulator without KVM

Hello everyone,

I just started to lean android on Linux platform 32 bit OS. I installed android sdk and eclipse. But Android emulator is not working.

There is a message "KVM is not installed/properly installed" when launching android emulator. I checked evrything. And I found that my hardware configuration doesn't support hardware virtualisation Intel x86 Atom Processor codename "Pineview". Hence unable to install KVM and therefore unable to launch android emulator.

Is there any way I could work without KVM?

HAXM silently crashing on OS X 10.9.5

Installed latest version of HAXM manually on 10.9.5 with latest version of Android Studio.

BUILD SUCCESSFUL
Total time: 14 seconds
Built the following apk(s):
    /Development/todo-lite/platforms/android/ant-build/CordovaApp-debug.apk
WARNING : no emulator specified, defaulting to Tab_S_style
Waiting for emulator...
HAX is working and emulator runs in fast virt mode

There's nothing logged in the console/system logs at all.

Application won't install (it used to)

Hi, I published an app to the Google Play store using Construct 2 and Intel XDK. I recently wanted to update the app and when trying to test on my device, it won't let me install the latest build (Crosswalk for Android). I tried clearing my cache, uninstalling the game, a previous build, another device and then finally tried a completely different apk. Any idea what might be wrong? I am using AdMob which was part of the problem I had before, but I even tried completely deleting AdMob from my game and I still can't install it.

Desktop gets shifted horizontally on Intel BayTrail, ASUS Transformer Pad TF103

Dear all,

while testing my app on the Atom Z3745, the screen suddenly got rotated right by a few hundred pixels. The pixels shifted out on the right side were displayed on the left side, but one pixel line lower.

This screen rotation problem was not related to my app, it persisted on the Android desktop after exiting my app.

The solution was to press the on/off button twice, then the desktop was OK again.

Since this shift could be an issue in the graphics driver, I'm reporting it here.

The problem appeared randomly twice this evening.

Regards,

OpenGL/ES texture format GL_BGRA broken in Intel BayTrail Android Driver

Dear all,

I tested my app on Android 4.4 with Intel(R) HD Graphics for BayTrail , OpenGL ES-CM 1.1, and unfortunately no textures were shown at all.

I now tracked down the problem: Even though the Intel BayTrail driver reports to support the extension GL_EXT_texture_format_BGRA8888, using glTexImage2D with format GL_BGRA seems to create a mess, so that no more textures are displayed at all. All is fine if GL_RGBA is used instead.

Test system was an Asus Transformer Pad TF103C.

*** FIX *** HAXM 1.1.1 on Windows 7 64bit

For people having install issues with HAXM - specifically this issue:  "Failed to configure driver: unknown error. Failed to open driver".
I discovered that the issue is the digital signed catalog for the 64bit driver is named wrong in the install.
It is named IntelHaxm_x64.cat in the inf file for the driver: CatalogFile.ntamd64=IntelHaxm_x64.cat
but the file that is in the folder is named  intelhaxm_x86.cat - this is the name for the 32bit OS driver.

So this is what I did to fix it.

Driver problems whilst rooting a Dell Venue 8 (3840)

We have some Dell Venue 8's (3840 Merrifield, running 4.4.4) that we are doing a software project with that requires us to root the units, and I very carefully followed the steps provided in http://opensource.dell.com/releases/Venue_8_3840_Merrifield/developer-ed..., and used the drivers and packages that can be downloaded from the opensource.dell.com site, exactly per instructions.

 

Iscriversi a Android* Applications on Intel® Architecture