VS2010 RTM: error trying to compile projects with Composer

VS2010 RTM: error trying to compile projects with Composer

imagem de Ricardo Costa

Hello,

After installing VS2010 RTM, I get the following error after selecting "Use Intel C++" on any C++ project and trying to compile it:

C:\\Program Files (x86)\\MSBuild\\Microsoft.Cpp\\v4.0\\Platforms\\Win32\\PlatformToolsets\\Intel Parallel Composer 2011\\Microsoft.Cpp.Win32.Intel Parallel Composer 2011.targets(37,5): error MSB4062: The "ICMessage" task could not be loaded from the assembly Intel.Build.ICLTasks.ICMsgTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=3c0c138f5bbab72f. Could not load file or assembly 'Intel.Build.ICLTasks.ICMsgTask, Version=12.0.0.0, Culture=neutral, PublicKeyToken=3c0c138f5bbab72f' or one of its dependencies. The system cannot find the file specified. Confirm that the declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.

Any clues about what could be causing the problem?

Thank you,
Ricardo.

12 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de mark-sabahi (Intel)

Hi Reicardo,

Thanks for the problem report. I will investigate this issue and get back to you.

--mark

imagem de mark-sabahi (Intel)

Ricardo,

Below is what I did and did not see the problem you reported:

1. old system state: VS2008,VS2010 RC & Composer 2011 beta

2. uninstalled Composer 2011 beta, uninstalled VS2010 RC

3. installed VS2010 RTM, installed Composer 2011 beta

4. tested a project created with the old system -- no issue.

Did you install VS2010 RTM on top of the VS2010 RC (e.g. attempting an auto upgrade rather than a clean uninstall/install) ?

Does uninstalling and reinstalling Parallel Composer Beta resolve the problem?

Thanks,
--mark

imagem de Ricardo Costa

Hi,

I did uninstall VS2010 RC before installing RTM,although I did not reinstall Composer beta. It seemed to be working in RTM without the need of a reinstall since the toolbars andoptions were available. I've now reinstalled Composer and it's working again.

However, I have a new issue. When I try running the application from the IDE by pressing F5 or Control+F5, I get an error message saying: "Object reference not set to an instance of an object.". The .exe file is generated normally and I can run it from Explorer, but not from within the IDE.

imagem de mark-sabahi (Intel)

Hi Ricardo,

Did my previous update help at all?

Thanks,
--mark

imagem de Ricardo Costa

Hi Mark,

I've installed Update 1 and I still get "Object reference not set to an instance of an object." while trying to run my project from the IDE (F5 or Ctrl+F5)when it'scompiled by Composer.

Any ideas?

Thanks.

imagem de mark-sabahi (Intel)

Hi Ricardo,

Please click Project\Properties\Intel Debugging\ and set "Parallel Debug Environment" to "Disabled" and see if that resolves the issue.

Thanks,
--mark

imagem de Ricardo Costa
Quoting Mark Sabahi (Intel) Hi Ricardo,

Please click Project\Properties\Intel Debugging\ and set "Parallel Debug Environment" to "Disabled" and see if that resolves the issue.

Thanks,
--mark

Yes, it does. The "Enabled" option also works. I only get the error message when "Auto" is set, or when the field is blank.

imagem de mark-sabahi (Intel)

That's great Ricardo; I'm glad the workaround worked for you. The development team is looking into this issue. We will keep you posted of the progress.

Thanks,
--mark

imagem de mark-sabahi (Intel)

Ricardo,

Can you send me the project you are using so I can reproduce the error?
If it's not possible to get the entire solution, you can only send the solution and project files without the .cpp and .h files.

Thanks,
--mark

imagem de Ricardo Costa

I've sent the files by email. Thanks.

imagem de mark-sabahi (Intel)

Thanks for the test case Ricardo. The development team believe they have resolved the issue. The fix should be available in one of the upcoming releases.

--mark

Faça login para deixar um comentário.