OS* X Mountain Lion and Xcode 4.4 NOT supported in 12.1 U11 or older

OS* X Mountain Lion and Xcode 4.4 NOT supported in 12.1 U11 or older

imagem de Ronald W Green (Intel)

25 July 2012: Intel compilers support for OS* X Mountain Lion:

Intel compiler support for OS* X Mountain Lion and Xcode* 4.4 with SDK 10.8 will arrive in the next couple of months. AT THIS TIME THERE IS NO OFFICIAL SUPPORT for this OS and Xcode combination.

There are known issues with Xcode 4.4 integraton with Intel Composer XE 2011 SP1 for Mac OS* X Update 11 aka version 12.1.5.344 build 20120612 and all older versions.

23 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Aren't you guys part of the Apple developer program so that you get beta and pre-release versions of new versions of OSX? I would think you would have these problems resolved on the day Apple releases the new OSX. I installed Mountain Lion last night and immediately saw the problems trying to use Intel Fortran 12.1.5 from the command line. Luckily, I backed up before and am now reverting back the the previous OSX.

I've already decided not to renew my Windows subscription for Intel Fortran (see following thread in that forum http://software.intel.com/en-us/forums/showthread.php?t=105777&o=a&s=lr ). Looks like I'll be doingthe same with myOSX version especially in light of the fact that the latest gfortran (4.7) now suprisinglyproduces faster codefor my application.

Al Greynolds
www.ruda.com

imagem de Steve Lionel (Intel)

Yes, we are. But Apple routinely makes changes just before release and we have to cope with it. They break things so often that you generally cannot count on tools released before the Apple release to keep working. Apple frequently breaks Xcode integration and introduces incompatibilities in their libraries and tools. We've already got the changes in that we need and will release them as soon as we can.

We'd be happy to work with you on the "optimization problems" you are seeing.

Steve

Sorry for singling you guys out. Just saw an article where a lot of AutoCAD versions now don't work on Mountain Lion andAutoDesk can'tgive a definite timeframefor providing fixes.

Al

imagem de Steve Lionel (Intel)

BTW, Apple also doesn't tell us when they're going to release a new version. We find out when you do.

Also, we just discovered that Apple is claiming that Xcode 4.4 works on 10.7.4, which is not a combination we were expecting and have not tested yet.

Steve

What is the last version of xcode to work with the new intel release?

imagem de Steve Lionel (Intel)

4.3 works with the current release (Update 11)

Steve

I'm running Lion 10.7.4, I've downloaded Xcode 4.3.3 and put in the applications as Xcode copy (since Xcode 4.4 is also there). I reintstalled intel fortran and followed the instructions on how to set up a fortran project, I picked Fortran source files under project but the intel compiler does not appear in the Using tab. Am I doing something wrong?EDIT : I just needed to restart my computer and it was there. Ignore this post.

Since I work only from the command line, I tried installing the latest Xcode 4.4 Mountain Lion Comand Line Tools and now 12.1.4 works just fine with it.Al

imagem de Ronald W Green (Intel)

Al,

Glad it works with your application, but there are corner cases in our quality and validation tests that fail. That's why we say it's not "officially supported". Yes, command line you have the best chances, but there are multiple things wrong with the Xcode 4.4 IDE integration.

So make sure to test thoroughly to validate your command line executables are correct.

We should have an updated compiler with official support for 10.8 and Xcode 4.4 in the coming months.

ron

I'm a little confused by the phrasing. Just to make sure, you're saying mountain lion and xcode 4.3.3 is not officially supported by the latest build either? Is that correct?

Quoting thebuttonfreak
I'm a little confused by the phrasing. Just to make sure, you're saying mountain lion and xcode 4.3.3 is not officially supported by the latest build either? Is that correct?

I'd also appreciate a response to the above question

imagem de Steve Lionel (Intel)

The supported combinations of OS X and Xcode are given in the release notes for each update. For Update 11, the most recent (as of this writing), it says:

One of the following combinations:
o Mac OS* X 10.7 and Xcode* 4.3/SDK 10.7 with Command Line Tools component of Xcode installed
o Mac OS* X 10.7 and Xcode* 4.2/SDK 10.7
o Mac OS* X 10.7 and Xcode* 4.1/SDK 10.7
o Mac OS* X 10.6.8 and Xcode* 3.2.5/SDK 10.6
o Mac OS* X 10.6.8 and Xcode 4.0/SDK 10.6

You will not find either OS X 10.8 "Mountain Lion" or Xcode 4.4 on this list. Xcode 4.3 is supported with OS X 10.7 "Lion".

We will, within a few weeks, be releasing a version that supports the combination of OS X 10.8 and Xcode 4.4.

Steve

Hi

Sorry if this is a dumb follow up question, but I have just upgraded from Snow Leopard to Mountain Lion and therefore broken my Intel Composer XE 11 for Fortran. It was not clear to me in the last post above whether a fix will be or has been available for V 11?

If a solution is available could I please get a pointer to it? Thanks for your help. Let me know if I need to get additional information on the version etc.

Thanks,

John

imagem de Steve Lionel (Intel)

You need to be careful when referring to product versions. What you have is Composer XE 2011, which is compiler version 12.0 or 12.1. We did have a version 11, but that is from 2008-2009.

Mountain Lion is supported in Composer XE 2013 (compiler 13.0), and if your license is reasonably current you should be able to get that from the Intel Registration Center (https://registrationcenter.intel.com/)

Steve

Apologies re: mixing up compiler numbers. That illuminates my limited experience.

Unfortunately my license is expired and I am in academia without a current grant that can pay for a new license.

Is there any way to run XE 2011 on Mountain Lion?

Cheers,

John

imagem de Steve Lionel (Intel)

Update 12 to Composer XE 2011 will run on Mountain Lion (with Xcode 4.4). Nothing earlier.

Steve

Sorry for yet another simple question, but how can I tell if I have update 12? It looks as though I am running version 12.0.3 (see below). Would that be only update 3?

ifort -v
Version 12.0.3

Cheers,

John

imagem de Ronald W Green (Intel)

yes, that is Update 3: ... 12.0 Update 3

full mapping of versions: http://software.intel.com/en-us/articles/intel-compiler-and-composer-upd...

imagem de Steve Lionel (Intel)

But if your license does not allow you to install Composer XE 2013, you probably won't be able to get Update 12 either, since we license by date, not version number.

Steve

Thanks Steve,

My license expired on January 14, 2012. Would that be before update 12?

Also, please let me know if this is the sort of information that I could better obtain from some other source (e.g. customer service) rather than taking the space (and your time) on this forum.

Cheers,

John

imagem de Steve Lionel (Intel)

Yes, that's before Update 12. It's also before Mountain Lion.

This forum thread told you that Update 11 and older did not support Mountain Lion. You are welcome to ask questions here - folks such as Ron, Kevin, Annalee and I are compiler tech support - that's what we're here for. If you want information about which compiler was released when, you can check the Release Notes articles Fortran Composer XE 2013 and Fortran Composer XE 2011.

If you have licensing-specific questions, there's http://software.intel.com/en-us/forums/intel-software-development-produc...

Steve

Got it. Thanks.

Faça login para deixar um comentário.