IMR_Init fails with Memory allocation problem

IMR_Init fails with Memory allocation problem

Hi,

I'm using redirection library for IDE-R.
IDE-R is working properly for sometime and after that i'm getting memory allocation error(IMR_RES_MEMALLOC_FAILED)for IMR_Init.
I'm calling IMR_Init as below
IMR_Init(NULL, "C:\\Test IDER\\MC.ini")
Once after getting this error IDE-R is not working anymore.
Is there any limitation related to this type of error?

Thanks,
Mani

5 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Hello,
That memory allocation error is from redirection library on the system where it is running, probably due to insufficient memory available.

If you are only running IDER calls on it and it is running out of memory you may want to ensure that you are closing your session (IMR_IDERCloseSession) and shutting down the library (IMR_Close)after each use. This will return system resources being used like memory.

Hi Lance Atencio,

I'm properly closing the session using (IMR_IDERClosesession) and shutting down the library using (IMR_Close).I tried closing IDE-R application and tried again, always getting memory alocation error only.
I have enough memory in the system.
IfI uninstall and install theIDE-R application, it's working fine.

Thanks,
Mani

What application is it that you are uninstalling/reinstalling?

I'm assuming you are using a redirection library from the latest AMT SDK to build an application.

Hi Lance Atencio,

I have written a muti threaded(pthread) C++ application using VS2008 which uses redirection library from the latest AMT SDK and it will communictae to 3 AMT system and redirect the IDE-R.
I have created wixinstallation for this IDE-R application and tried uninstall/install.
This IDE-R application is working without any problem for some time, after that i'm always getting error as memory allocation failedfor IMR_Init problem. As you said, it may be related to insufficient memory, I checked system memory, it's normal only.Even I rebooted the system and tried the IDE-R applcation it is always failing with memory allocation error.
what could be the problem?

Thanks,
Mani

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!