Problems with devices

Problems with devices

Hi all,

We've got a demo C5 from Motion France. We can't seem to get any of the devices (camera, rfid reader) working.

We areusing Visual Studio 2005, c#.

First of all, none of the included samples from the Intel SDK work. They crash as soon as we start them and we get the standard Windows message asking if we want to report his to Microsoft or not.

So we had a look at the sourcecode of these examples and tried to build our own application. As soon as we call a constructor of any device, like

Camera c = new Camera();

or

RfidReader r = new RfidReader();

we get the following error when the application is run on the C5.

Value cannot be null.

Parameter name: format

Object reference not set to an instance of an object

When i run the application on our development laptop it gives the error (in case of the camera)

Camera device named '' was not found (Unable to get last error)

We're pretty much stuck since we can't even make an instance of these objects.

Has anyone every experienced this behaviour ?

Many thanks.

13 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Hi FiveZero,

It sounds like there may be some problems with the software
installed on the C5. Was the C5 you received fresh out of the box, or had some
others been using and testing with it? If it was not fresh out of the box with a
fresh software image, I would certainly suggest downloading the image from
Motion and installing it on your C5. Otherwise there is no way to really know
what has happened with the C5 previously.


The second thing to be aware of is the difference is the version of
the MCA platform driver installed on the C5 you have, and the version of the MCA
SDK that was used to create your applications, or even the MCA
samples.


Most Motion C5s still have the MCA platform driver version 1.0
installed on them. The latest version of the MCA platform driver is versions
1.11. If you try to run the MCA SDK samples (or your own applications) based on
the MCA SDK v1.11 on the C5 with an MCA platform driver version of 1.0
installed, you will run into some problems. However, note that the opposite is
not true - samples and code created using the MCA SDK v1.0 will work fine on the
MCA platform driver v1.11.


So my suggestion would be to re-image the C5 you have with the
latest version from Motion Computing that includes the MCAplatform driver
v1.11. Then any sample or application you created from the MCA SDK v1.0, v1.0,
or v1.11 will run correctly.


Also, please note that you should never install the MCA SDK
directly onto the Motion C5. Installing the MCA SDK onto a machine that already
has the MCA platform driver on it will cause problems. The MCA SDK should only
be installed on a development machine due to the deviceloopback configuration
it uses. If you want to install samples from the MCA SDK onto the Motion C5,
just manually copy the samples from your development machine that has the MCA
SDK already installed on it.


Thanks,
Steve

Hi Steve,

Thank you very much for the amount of info you provided.

The C5 we receivedisn't new and has been used by othersfor demo purposes.

If you say re-image ... do you mean a clean install of Windows ? Or just the C5 software ? Do you have a download link where i can find the exact software i need ?

Once again: thanks very much.

FZ

Hi FiveZero,

Motion has a restorable image for the C5 which includes the OS, as well as all of the drivers and software that should be on the C5. This is the OS image they load on the system when it is built new at the factory. Motion Computing can post the OS image for you on their FTP site if your local Motion representative does not have it. I realize it is a pain to get the image, burn it to DVD, and then install the image, but it is the best way to start so you know the system is setup correctly. Just make sure you get their latest image which includes the v1.11 of the MCA software alonf with several other updates Motion has loaded into the image.

To get the image posted contact Motion Computing's support team at the URL below:

http://www.motioncomputing.com/about/contact.asp#

Thanks,
Steve

Hi Steve,

Just wanted to let you know that i managed to fix the problem. I downloaded and installed the MCA software version 1.11 on the C5 and that fixed the problem.

Let me know if you're ever in Belgium ... i'll buy you a beer (or two)

Many thanks again.

FZ

Hello Steve,

I've got a Motion Computing C5 with Windows Vista as operating system. MCA Platform Driver v1.11 was installed yesterday. Since the installation of the new PD the devices (Barecode reader, and camera) cannot be found anymore. When I press the Camera Button There is an error message by the ToolTray.exe. It says:
"This application has failed to start because MCBttnEC.dll was not found. Re-Installing the application may fix this problem.

Another issue is as follows:
I created a BarecodeDemo.jar file on my PC (SDK v1.11) with the Example from the MCA/Exmple/Java/BarcodeDemo/barcodedemoJava.java file. When I start the jar with java -jar BarecodeDemoJava.jar on my Motion Computing C5 the Application starts. But when I press the "Populate Supported Types" Button I recieve an Error message. It says:
"Barecode Reader device named was not found. (Unable to get last error)"

Many Thanks

Markster

Hi Markster,

Did you get the Vista image you have installed on the C5 from Motion Computing? Or, is it just a standard Vista install?

Thanks,

Steve

Hello Steve,

I'm working with a standard Vista install on the C5 from Motion Computing.

Thank you

Markster

Hello Steve,

I was able to get the camera working on my C5 running with MCA Platform Driver version 1.11. When pressing the Camera Button, the standard window opens. I was also able to start the CameraDemoJava.jar application.
I copied the the library MCBttnEC.dll from MCA PD version 1.00 into my Intel/MCA/Bin folder. It might be that this is not the best solution but I'm happy with that at the moment. I'll meet the "support person" for the C5 next week and hope to get further information.
Thanks for your help.

Markster

Thanks for the update Markster.I am trying to get the latest Vista image from Motion so we can do some testing with it. Let me know if you discover anything else, and I'll do likewise.

Thanks,

Steve

Quoting - Steven Murray (Intel)

sound not working sound dives not instalt so i want
installed on it pls .


Thanks,
dhanish

Quoting - dhanish

Quoting - Steven Murray (Intel)

i re instal windows xp then not working in sound icon message sound dives not install so i want
installed on pls sent driver in my email.


Thanks,
dhanish

Hi dhanish,

Intel only provides and supports the MCA software. The sound/audio drivers are not part of the MCA software. Please contact the MCA hardware vendor to get the OS image of your choice from them. The OS image will included the audio drivers for your system.

Thanks,
Steve

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!