Problem with Intel MPI

Problem with Intel MPI

When trying to run Intel MPI I'm getting the following error message :

I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): this device was not built to run on the processor in your system: libmpi.rdssm.so
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device
I_MPI: [0] set_up_devices(): will use static-default device

My Cpu is :

[1015] cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 5
model name : AMD Opteron Processor 244
stepping : 8
cpu MHz : 1793.836
cache size : 1024 KB
physical id : 255
siblings : 1
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 pni syscall nx mmxext lm 3dnowext 3dnow
bogomips : 3522.56
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts ttp

How can I fix this??

4 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

I'm not certain what the conditions might be for use of rdssm device. Does it work with the usual default sock device? It shouldn't be trying rdssm unless you asked for it by command line option or environment variable. Did you set both PATH and LIBRARY_PATH to the same architecture, and is your application build for the same? You must use intel_mpi_10/bin64 and /lib64 if your application is built in 64-bit mode, or the 32 bit paths, if built in 32-bit mode. I assume you are running 64-bit OS, since you shouldn't have a choice under 32-bit OS.

We are trying to benchmark the Ammasso nic cards and that is why we are using rdssm. Their implementation of MPI is buggy and is not working for us at this time. They recommended Intel MPI. I will check on the things you have pointed out, but I followed a document Ammasso supplied to use their product with Intel MPI.

You will likely get more useful and quicker assistance if you submit this problem to the Intel MPI LIbrary tech support through Intel Premier Support (http://premier.intel.com).

Your use of non-Intel processors could be a big factor in this problem. If the library you're trying to use attempt to use features not supported on your target platform, I could see that this would be the error message that might be printed.

--clay

Message Edited by ClayB on 07-18-2005 12:35 PM

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!