*.f file icons look like unassigned file type icons

*.f file icons look like unassigned file type icons

Why don't my *.f and *.f90 file icons show some kind of Fortran file type when I install version 6.5 in Windows 2000? The Fortran source files open fine with Microsoft Develompent Studio when I double-click on their icon, but the icons look like unassigned file types.

Can the appearance of the icons be fixed?

21 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

In any Windows Explorer window, select Tools..Folder Options..File Types. Scroll down the list until you find the F file type. Click on it, then click on Advanced - this will change the attributes for all "Fortran Source File" types. Click Change Icon. The icon I like to use is in Program FilesMicrosoft Visual StudioCommonMSDev98BinMODWIZ.EXE

Steve

Steve - Intel Developer Support

Thanks, Steve.

In fact, I found F90 icons in the DF98/BIN directory. A couple of questions, though:

1. Why doesn't installing Fortran associate the icons for me?

2. The MODWIZ.EXE icon represents a specific application. I would think that there would be a UNIQUE icon to a represent Fortran *source* file. However, the only Fortran source icons I could find were those for F90 files -- none that would be appropriate for more general *.f or *.for files.

We don't associate an icon with the file types. It's a good idea. The Modwiz icon is the closest thing we have to a "Visual Fortran" icon - I don't care for the icons found in the DF98BIN folder.

Steve

Steve - Intel Developer Support

OK now I'm finally here. I KNOW there are are other icons in Visual Fortran 6.5 besides the f90 icon. How do I know that? Because when I open a fixed FORTRAN file, the icon in the left corner of the edit window is not the f90 file icon. Why do you say that you do not associate different types of FORTRAN files when you do?
Now I would like to know where these icons are. If you want a picture we can do that. But you can see it for yourself by opening a .for file (try Celsius.for) in the edit window and look in the upper left hand corner. What do you see there? Make sure the Window is not maximized or minimized. You know, where you can resize it yourself.
Mine shows a black and White icon with F above the other letters OR. LOOK!
Where are these icons? Obviously they must reside with Visual FORTRAN. Thank you.

In Developer Studio, Open any of the .EXE or .DLL files (e.g. DF.EXE) in your DC/BIN/ directory as Resources' (N.. auto' is the default) and you will find icons that you can copy and use/edit using the Developer Studio icon resource editor to suit. You just have to look around. DF.EXE has three F90 icons you could use.

(P.S. An icon extractor program will automate the finding and classifying of icons, but you will have to pay for it e.g. www.gregorybraun.com)

Well the response was fast and I appreciate it. Unfortunately I don't think you understood the icons I was looking for. In I:Program FilesMicro soft Visual StudioDF98Bin has no all's in it and every ex file either has just the f90 icons or nothing. Check them you will see.
So the other place is I:Program FilesMicro soft Visual StudioCommonMsDev98Bin. There is some ells there. But again none have any FORT RAN icons. What I am looking for is what I said I was looking for in my first post. Thanks anyway.

On my CVF5 system, it's in

C:Program FilesDevStudioSharedIDEBinIDEDEVFOR.PKG

Probably something similar in CVF6.x

Jugoslav

Jugoslav www.xeffort.com

6.5a - First and second icons in the same file Jugoslav noted above (IDs 3011, 3012).

Steve was correct when he said that they don't associate icons with files (how do I know this? just check explorer). The fact that the DevStudio MDI window for the source files has an icon does nothing to refute what he said. If you want to associate fortran file types with these icons in explorer, go ahead now that you know where they are. Anthony's advice was enough for anyone to find these and any other icons that ship in CVF. LOOK!

In the future perhaps CVF will associate icons with .f90 and .for source files. If so, maybe something a little more colorful than the ones noted above. ;-)

-John

Thank you Jugoslav. The files I was looking for were right in the place you described. Now John. Anthony was not right. Read what he said. he referred to the icons I did not want. So he got it wrong. Big deal. He tried and I thanked him. But you John and Jugoslav have answered what I needed to know. Jugoslav for the location and John for the ID. All done.

On my CVF 6.5A system, the file is C:Program FilesMicrosoft Visual StudioCommonMSDEV98BINIDEDEVFOR.PKG. Please explain how one opens this file as a resource within Developer Studio to view and copy icons out of it.

Mike Durisin

Disregard my question above. I found that I need to list the DEVFOR.PKG file in Explorer's Tools|Folder Options|File Types to see and choose an icon.

Mike Durisin

Hi Mike,

Anthony briefly described how to open the file in DevStudio to view/copy/... the icons/resources. Select File | Open from the menu. At the bottom of the Open dialog box select 'Resources' in the 'Open as' drop down. You may also want to change the 'Files of type' or optionally select the Read Only checkbox. This is the method I used to find the 'wanted' icons. Jugoslav probably did too, though I wouldn't be shocked if he just knew it off the top of his head! :-) (Hi, Jugoslav)

-John

Nope, I had (and still have, for a single reason -- it has built-in IMSL help ;-)) FPS4 installed and I've always had those icons for .f* files -- I didn't even know that CVF does not associate icons. In FPS4, these were located in a similar place, so I just took a look in explorer's "File types" dialog and found an analog in CVF.

(Hi, John, wha'bout the deadline? :-))

Jugoslav

Jugoslav www.xeffort.com

Jugoslav:
Do you have Microsoft Powerstation FORTRAN installed in the same partition as Compaq Visual FORTRAN?

Yes, and they co-exist without problems. Only inconvenience I had is that I had to manually associate file types with CVF's MSDEV (but I'm not sure which one I installed first when I migrated to a new computer). Yes, another thing -- don't let FPS to add its library and include paths in PATH environment variable.

Jugoslav

Jugoslav www.xeffort.com

well that is interesting. No path variables for MPS! hmm. Can't we put the libraries and includes in at the IDE but under CDF's? How can MPS operate if it doesn'tr have any paths of it's own?

Jugoslav:
When you say keep the path and environmet away from FORTRAN Power Station do you mean out of Autoexec bat but set it in the IDE itself?

Hey Jugoslav,

How 'bout an extension?? ;-)))

-John

AFAIK environment variables INCLUDE, PATH and LIB aren't used for normal work with IDE; they're useful only when you compile from command prompt. So, there's no need to set any environment variable from Autoexec.bat (as far as FPS is concerned) because both IDEs keep their paths to compiler and linker in registry. Thus, default installation settings with only "don't add env. vars to Autoexec.bat" worked OK for me.

Jugoslav

Jugoslav www.xeffort.com

Correct - environment variables are used only when building from a command prompt. The IDE has its own separate set of registry entries for these paths.

Steve

Steve - Intel Developer Support

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!