Including libraries in RPM package

Including libraries in RPM package

imagem de Praveen
Hi, Below the list of libraries that are required by our app as dependencies. Developer is unable to include these libraries inside the RPM package for making them available while the app is installed by the user on Moblin. Could you please help us out in this? libatk1.0-0 (>= 1.20.0), libc6 (>= 2.3.6-6~), libc6 (>= 2.4), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libgcrypt11 (>= 1.4.0), libgda4-4, libglade2-0 (>= 1:2.6.1), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.16.0), libpango1.0-0 (>= 1.14.0), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4) AND gtk+-2.0 >= 2.8, libglade-2.0 >= 2.6.0, libgda-sqlite-4.0, libgda-4.0, adpcore, adpruntime Regards, Praveen
5 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de DG Rooven (Intel)

Praveen,

The information available on the link http://moblin.org/documentation/moblin-sdk/coding-tutorials/moblin-compliance might be helpful.

• Make sure your application uses the libraries and versions included in Moblin v2 images. These are shown in the Moblin v2 Library list: http://moblin.org/sdk/moblin-v2-development-libraries
• Use Linux Project Generator (http://moblin.org/projects/linux-project-generator) to select the correct libraries and versions (screenshot) when starting a new project.
Verify your application can be built and run in the Moblin v2 environments loaded from one of the pre-built Moblin v2 development images(http://moblin.org/documentation/moblin-sdk/download-development-images).

Regards
Rooven

Intel® Customer Support
Intel® Atom™ Developer Program
Intel® AppUp(SM) Center

Regards, DG Rooven

The ADP_Initialize call always returns ADP_NOT_AVAILABLE when I try to run my application on Moblin. Can anyone please let me know what I am missing here. Any help is greatly appreciated.

imagem de Hal

Hello Mahesh,

If you are running your program locally using ATDS, use the DEBUG GUID
If you are using BETA testing to run your program, you will need to use your assigned GUID.
ADP_NOT_AVAILABLE is returned if the Client Agent “goes away” while the application is running.
There are many good threads on this subject including this one: http://appdeveloper.intel.com/en-us/node/980

Regards
Hal G.
Technical Support Team
Intel® Atom™ Developer Program
Intel AppUp(SM) Center

imagem de BrianDevArch

Mahesh,

Is ATDS running when you experience that exception?

If so, please paste the contents of the ATDS console window and I will try to assist you.

If not, please start ATDS prior to testing your application locally.

Faça login para deixar um comentário.