meego xorg error!

meego xorg error!

when I boot the meego OS, I got the following error log about xorg, can anybody help me? This is a pre-release version of the X server from The X.Org Foundation. It is not supported in any way. Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/. Select the "xorg" product for bugs you find in this release. Before reporting bugs in pre-release versions please check the latest version in the X.Org Foundation git repository. See http://wiki.x.org/wiki/GitPage for git access instructions. [ 1865.965] X.Org X Server 1.8.99.905 (1.9.0 RC 5) Release Date: 2010-07-14 [ 1865.965] X Protocol Version 11, Revision 0 [ 1865.965] Build Operating System: Linux 2.6.31.12-0.2-desktop i686 [ 1865.965] Current Operating System: Linux localhost.localdomain 2.6.35.2-6.1-mrst #1 SMP PREEMPT Fri Aug 20 13:04:37 UTC 2010 i686 [ 1865.966] Kernel command line: root=/dev/mmcblk0p1 ro pci=noearly console=tty1 console=ttyS0 earlyprintk=mrst loglevel=8 s0ix_latency=160 [ 1865.966] Build Date: 18 August 2010 07:30:49PM [ 1865.966] Build ID: xorg-x11-server 1.8.99.905-2.5 [ 1865.966] Current version of pixman: 0.18.2 [ 1865.966] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. [ 1865.967] Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 1865.968] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 1 16:26:26 1960 [ 1865.969] (==) Using config directory: "/etc/X11/xorg.conf.d" [ 1865.970] (==) No Layout section. Using the first Screen section. [ 1865.971] (==) No screen section available. Using defaults. [ 1865.971] (**) |-->Screen "Default Screen Section" (0) [ 1865.971] (**) | |-->Monitor "" [ 1865.971] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. [ 1865.972] (==) Automatically adding devices [ 1865.972] (==) Automatically enabling devices [ 1865.972] (==) FontPath set to: catalogue:/etc/X11/fontpath.d, built-ins [ 1865.973] (==) ModulePath set to "/usr/lib/xorg/modules" [ 1865.977] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices. [ 1865.977] (II) Loader magic: 0x821b560 [ 1865.977] (II) Module ABI versions: [ 1865.977] X.Org ANSI C Emulation: 0.4 [ 1865.977] X.Org Video Driver: 8.0 [ 1865.977] X.Org XInput driver : 11.0 [ 1865.977] X.Org Server Extension : 4.0 [ 1865.992] (--) PCI: (0:0:1:6) 8086:080d:0000:0000 rev 0, Mem @ 0xff009000/1024 [ 1865.992] (--) PCI:*(0:0:2:0) 8086:4102:0000:0000 rev 2, Mem @ 0xff200000/1048576, 0xd0000000/268435456, 0xcffc0000/262144, I/O @ 0x00001000/8 [ 1865.993] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory) [ 1865.993] (II) LoadModule: "extmod" [ 1865.996] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so [ 1865.997] (II) Module extmod: vendor="X.Org Foundation" [ 1865.997] compiled for 1.8.99.905, module version = 1.0.0 [ 1865.997] Module class: X.Org Server Extension [ 1865.998] ABI class: X.Org Server Extension, version 4.0 [ 1865.998] (II) Loading extension MIT-SCREEN-SAVER [ 1865.998] (II) Loading extension XFree86-VidModeExtension [ 1865.998] (II) Loading extension XFree86-DGA [ 1865.998] (II) Loading extension DPMS [ 1865.998] (II) Loading extension XVideo [ 1865.998] (II) Loading extension XVideo-MotionCompensation [ 1865.998] (II) Loading extension X-Resource [ 1865.998] (II) LoadModule: "dbe" [ 1866.001] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so [ 1866.002] (II) Module dbe: vendor="X.Org Foundation" [ 1866.002] compiled for 1.8.99.905, module version = 1.0.0 [ 1866.002] Module class: X.Org Server Extension [ 1866.002] ABI class: X.Org Server Extension, version 4.0 [ 1866.002] (II) Loading extension DOUBLE-BUFFER [ 1866.002] (II) LoadModule: "glx" [ 1866.004] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so [ 1866.005] (II) Module glx: vendor="X.Org Foundation" [ 1866.005] compiled for 1.8.99.905, module version = 1.0.0 [ 1866.005] ABI class: X.Org Server Extension, version 4.0 [ 1866.006] (==) AIGLX enabled [ 1866.006] (II) Loading extension GLX [ 1866.006] (II) LoadModule: "record" [ 1866.008] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so [ 1866.009] (II) Module record: vendor="X.Org Foundation" [ 1866.009] compiled for 1.8.99.905, module version = 1.13.0 [ 1866.009] Module class: X.Org Server Extension [ 1866.009] ABI class: X.Org Server Extension, version 4.0 [ 1866.009] (II) Loading extension RECORD [ 1866.009] (II) LoadModule: "dri" [ 1866.011] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so [ 1866.013] (II) Module dri: vendor="X.Org Foundation" [ 1866.013] compiled for 1.8.99.905, module version = 1.0.0 [ 1866.013] ABI class: X.Org Server Extension, version 4.0 [ 1866.013] (II) Loading extension XFree86-DRI [ 1866.014] (II) LoadModule: "dri2" [ 1866.016] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so [ 1866.017] (II) Module dri2: vendor="X.Org Foundation" [ 1866.017] compiled for 1.8.99.905, module version = 1.2.0 [ 1866.017] ABI class: X.Org Server Extension, version 4.0 [ 1866.017] (II) Loading extension DRI2 [ 1866.017] (==) Matched pvr as autoconfigured driver 0 [ 1866.017] (==) Matched psb as autoconfigured driver 1 [ 1866.017] (==) Matched vesa as autoconfigured driver 2 [ 1866.018] (==) Matched fbdev as autoconfigured driver 3 [ 1866.018] (==) Assigned the driver to the xf86ConfigLayout [ 1866.018] (II) LoadModule: "pvr" [ 1866.019] (II) Loading /usr/lib/xorg/modules/drivers/pvr_drv.so [ 1866.022] (II) Module PVR: vendor="X.Org Foundation" [ 1866.023] compiled for 1.8.99.905, module version = 1.5.3106 [ 1866.023] Module class: X.Org Video Driver [ 1866.023] ABI class: X.Org Video Driver, version 8.0 [ 1866.023] (II) LoadModule: "psb" [ 1866.029] (WW) Warning, couldn't open module psb [ 1866.029] (II) UnloadModule: "psb" [ 1866.029] (EE) Failed to load module "psb" (module does not exist, 0) [ 1866.029] (II) LoadModule: "vesa" [ 1866.034] (WW) Warning, couldn't open module vesa [ 1866.034] (II) UnloadModule: "vesa" [ 1866.034] (EE) Failed to load module "vesa" (module does not exist, 0) [ 1866.035] (II) LoadModule: "fbdev" [ 1866.040] (WW) Warning, couldn't open module fbdev [ 1866.040] (II) UnloadModule: "fbdev" [ 1866.040] (EE) Failed to load module "fbdev" (module does not exist, 0) [ 1866.040] (II) pvr: Driver for PowerVR chipsets: PowerVR SGX [ 1866.040] (++) using VT number 2 [ 1866.041] (WW) Falling back to old probe method for pvr [ 1866.042] drmOpenDevice: node name is /dev/dri/card0 [ 1866.043] drmOpenDevice: open result is 9, (OK) [ 1866.043] drmOpenDevice: node name is /dev/dri/card0 [ 1866.044] drmOpenDevice: open result is 9, (OK) [ 1866.045] drmOpenDevice: node name is /dev/dri/card0 [ 1866.045] drmOpenDevice: open result is 9, (OK) [ 1866.046] drmGetBusid returned '' [ 1866.047] drmOpenDevice: node name is /dev/dri/card0 [ 1866.048] drmOpenDevice: open result is 9, (OK) [ 1866.049] drmOpenDevice: node name is /dev/dri/card0 [ 1866.050] drmOpenDevice: open result is 9, (OK) [ 1866.050] drmOpenDevice: node name is /dev/dri/card0 [ 1866.051] drmOpenDevice: open result is 9, (OK) [ 1866.051] drmGetBusid returned '' [ 1866.051] drmOpenDevice: node name is /dev/dri/card0 [ 1866.052] drmOpenDevice: open result is 9, (OK) [ 1866.053] drmOpenDevice: node name is /dev/dri/card0 [ 1866.054] drmOpenDevice: open result is 9, (OK) [ 1866.055] drmOpenDevice: node name is /dev/dri/card0 [ 1866.055] drmOpenDevice: open result is 9, (OK) [ 1866.056] drmGetBusid returned '' [ 1866.056] (EE) SrvInit failed (error 1) [ 1866.056] (EE) No devices detected. [ 1866.056] Fatal server error: [ 1866.056] no screens found [ 1866.057] Please consult the The X.Org Foundation support at http://wiki.x.org for help. [ 1866.057] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
4 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de DG Rooven (Intel)

Hi dylanz,

For support regarding issues with Meego operating system, I recommend you visit Meego website for more information: http://meego.com/
Check that you are using the correct version of Meego operating system. The downloads can be found on this link: http://meego.com/downloads

Regards
Rooven

Intel AppUp(SM) Center
Intel AppUp(SM) Developer Program
Intel Technical Support

Regards, DG Rooven

thanks for reply

imagem de BrianDevArch

Dylanz,

This wiki entry gives the top reasons for the "no screens found" error condition. I have found that a majority of the time it is driver related. You should be able to find a compatible video card driver on the forums that Rooven provided a link to. Best of luck.

http://www.x.org/wiki/FAQErrorMessages#Ikeepgettingthemessage.3A.22noscreensfound.22

Faça login para deixar um comentário.