Problem with encapsulator - Application could not be verified

Problem with encapsulator - Application could not be verified

I've tried creating the simplest possible application (index.html with TEST in , and icon.png) and making it using the encapsulator. It installs fine but I get this error when trying to open it: "Application could not be verified". I've installed Intel AppUp (the store), do I need other software too? Thanks, Jack
11 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Just install the "Intel AppUp Software Debugger 2.0" (Download:, start the debugger and your Encapsulator 2.0 application.

Hi all

Actually, the Encapsulator uses the C++ SDK, so to make sure you won't have any issue, please install the correspondent SDK. You can find it here .

Regards, Sulamita

I've just got the same issue using encapsulator 2.0 alpha. I built an app in debug mode (without GUID). How to fix it?


I switched to Encapsulator 1.0 and it worked perfectly. Webkit implementation seems complete and it's very stable. 2.0 must have some issues still.

I managed to fix it. I've restarted the computer, reinstalled the app, installed Intel AppUp .NET SDK, ran the debugger and the application launched without any issues. I guess the problem was related to process ismagent.exe when I tried to run the app for the first time.

Hi Jack,

Please be so kind and let me know if the solution provided by Leon works for you too or not.


William C.
Technical Support Team
Intel AppUp(SM) Developer Program
Intel AppUp(SM) center

*Other names and brands may be claimed as the property of others.

Yes, I had also forgotten to run the debugger too - to be honest I had to guess to install the SDK in the first place and wasn't sure which version to choose, but being on a Windows box I chose .NET and the debugger came with it (presumably it comes with every SDK?). This fixed the problem for running apps in generals but I've had no more success with the 2.0 encapsulator - 1.0 lets my app run perfectly though so I've found no need to switch.

My name is Norm Chou and I'm a technical marketing engineer. I help developer push apps into the store and assist with general troubleshooting.

My support team informed of your issue with Encapsulator.

Did you try inputing a GUID before creating your app? That may fix your issue.

It would be awesome if you could contact me at I like to know if that fixed your issue or not.


Hi Norm,

First, thanks for your and your team's support and speedy responses to issues we report.

I did post the same problem/issue in a separate topic here but found this active trail. Sorry for the duplication.

About the GUID, the instructions on the Encapsulator 2.0 alpha says the GUID is OPTIONAL (NOT NEEDED) for "debug" versions of apps we're creating/testing in Encapsulator. I'm now confused which is the correct way to go, although I also tried supplying the GUID in a second attempt but got the same error message.

Two other developers appear to have resolved the issue by downloading the .NET SDK, restarting their computers, running the debugger that supposedly came with the SDK, and reinstalling their "debug"-version apps. Is this the best way to resolve the issue? If so, should these extra steps be included in the documentation (hopefully placed in a very visible and easy-to-find location) for Encapsulator?


Any update on this? I'm having the same issue.

My App will not work properly in encapsulator 1.0 as I believe it uses an older version of webkit.

I wanted to try out version 2.0 to see my web app would work in it.

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!