Installation to Ubuntu 12.04: Platform not Supported?

Installation to Ubuntu 12.04: Platform not Supported?

imagem de matthew s.

Hello all,

I have downloaded the Intel® Fortran Composer XE for Linux (l_fcompxe_ia32_2013.1.117) and am running Ubuntu 12.04 32 bit.  I have also tried the 64 bit version and the 2011 32 and 64 bit versions.  Upon attempting to install each of these, I have recieved the same message: 

"The package does not support the platform it being run on.  Please check to be sure the correct architecture of package has been downloaded."

I know that the 64 bit versions should not work on my 32 bit Ubuntu, but I tried them just to double check.  I have already conducted the following:

sudo apt-get install build-essential
apt-get install gcc-multilib
sudo apt-get install rpm
apt-get install openjdk-6-jre-headless

As well as:

$ sudo rm /bin/sh
$ sudo ln -s /bin/bash /bin/sh

I am a relative newbie to Linux and do not see any other references to such an error, so is there something that I am missing?  I desperately need this compiler for my thesis, so any help would be greatly appreciated!  Thank you!

 

6 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Kittur Ganesh (Intel)

Hi Mathew,
Please see this Knowledge Base article for tips on installing the Intel Compilers for Ubuntu and Debian:
http://software.intel.com/en-us/articles/using-intel-compilers-for-linux...

The above article should help. Let me know if you still have any furtther questions/clarifications.
Regards,
Kittur

imagem de matthew s.

Kittur - Thank you for your response. Unfortunately, I had already reviewed that article prior to posting and hence have run the relevant commands per instructions there, but still the problem persists. I cannot see any steps that I have not completed therein, particularly for Ubuntu 12.04. Again, any further advice would be greatly appreciated. Thank you again!

Matt

imagem de Kittur Ganesh (Intel)

This is strange. Did you try to do the following:
1. Uninstall the previous installation if any like before...(manually)

2. Make /bin/sh a symlink to bash and re-launch installation as follows:

$ sudo rm /bin/sh
$ sudo ln -s /bin/bash /bin/sh
$ sudo -s
# rm -rf /root/.rpmdb // delete any corrupt rpm database if any.... /**** See if you did this line? **?
and restart the installation like before:
$ ./install.sh

If you still have issues, then the only way for further investigation is for you to do the following and attach the log files:
1. Set the following environment variables:
% INTEL_LMD_DEBUG=1
% INTEL_LICENSE_FILE= Ex: INTEL_LICENSE_FILE=/home/myprod.lic

2. Now start the installation and use the license file option during install giving full path to the license file:

3. Check to see if the install completes successfully or you get any messages during the install on missing prerequisites etc.

If still issues, then could you please attach the following log files? You will find in /tmp directory:

/tmp/<*pset*.log
/tmp/<*issa*.log

Appreciate your patience. Also, what's your serial number of the product?

Regards,
Kittur

imagem de Ronald W Green (Intel)

Wait, did you do this:

apt-get install ia32-libs

You need the 32bit libraries.

imagem de Kittur Ganesh (Intel)

Thanks Ron.

Matt, BTW Ron is our expert on Ubuntu! Did you try out what he mentioned above? Did that help?

Regards,
Kittur

Faça login para deixar um comentário.