suspend does not work on ubuntu 12.04 laptop

suspend does not work on ubuntu 12.04 laptop

imagem de Michal Kvasnicka

During the installation of the Intel VTune Amplifier XE 2013 build 253325 the OS (ubuntu 12.04.1 LTS) I get the folowing warning: Installing Amplifier XE Sampling driver kit component... WARNING: NMI watchdog timer is enabled. Suggestion: turn off the nmi_watchdog timer before running sampling. When I turn off nmi_watchdog and reinstall, everything looks good, but the Ubuntu 12.04 turn on nmi_watchdog after each restart. After installation of the Intel VTune Amplifier XE 2013 build 253325 ,the Ubuntu 12.04.1 LTS (supported OS) is not able to suspend or hibernate on laptop (ThinkPad T410). After uninstallation Intel VTune Amplifier XE 2013 everything works OK. Is there any workaround how to solve this problem?

7 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Peter Wang (Intel)

[When I turn off nmi_watchdog and reinstall, everything looks good, but the Ubuntu 12.04 turn on nmi_watchdog after each restart.]
- add argument “nmi_watchdog=0” in /boot/grub/grub.conf , then reboot system

imagem de Michal Kvasnicka

Quote:

Peter Wang (Intel) wrote:

[When I turn off nmi_watchdog and reinstall, everything looks good, but the Ubuntu 12.04 turn on nmi_watchdog after each restart.]
- add argument “nmi_watchdog=0” in /boot/grub/grub.conf , then reboot system

Yes, I tried this, but the main problem with non-functional sleep and/or hibernate still persist. There must be something in Intel VTune Amplifier XE 2013 build 253325, what cause this problem on Ubuntu 12.04 (laptop). Coincidence with nmi_watchdog may be insignificant only.

Should I report this problem on your premier support site?

imagem de Peter Wang (Intel)

With VTune(TM) Amplifier XE installed, turn on the nmi_watchdog handler.
“sudo echo 1 > /proc/sys/kernel/nmi_watchdog”
And try to hibernate.

It was caused by NMI WDG? by Amplifier?

Yes. Feel free to submit this issue to Intel Premier, with log files after running "amplxe-feedback -create-bug-report "

imagem de Michal Kvasnicka

Quote:

Peter Wang (Intel) wrote:

Yes. Feel free to submit this issue to Intel Premier, with log files after running "amplxe-feedback -create-bug-report "

2 days ago I submit Issue (issue number: 690973) on Intel premier support, but still no relevant answer. Just a few clarification questions. Is that typical?

The problem is very unpleasent, especially on notebook, where suspend mode is very useful.

Hi Michal,

Just to reiterate some of what we discussed on Intel Premier support.
1. If you turn off the NMI watchdog timer, you will not be able to go into suspend/hiberate, So for your performance collections you should turn off the NMI, run your collection and then turn it back on again.
2. Notebook issue: In this issue you have identified an in our "power analysis" driver that we are investigating. The power driver should not be interfering with the suspend/resume functionality. Once we understand the cause, I will update you with our findings.

Please, let me know if you have any questions.

I have the same problem with suspending not working with vtune installed, when running on fedora on laptop. Has this been fixed?

Faça login para deixar um comentário.